Download views-7.x-3.10.tar.gztar.gz 1.57 MB
MD5: c9806ffd69448bc505a67e790f97da58
SHA-1: 494c954f5eb6472a0318fdd13d01a4177e8c0702
SHA-256: 4439d4b2fde09a26b1ab0fea519e9f95f79e68d3a4aaf20b214c0f0fee373594
Download views-7.x-3.10.zipzip 1.81 MB
MD5: 45246351588a7f9f74a7d8ba1e0554f4
SHA-1: a40ffe4573376a417d65323b73ddb702ae807a81
SHA-256: 15a907df661659a9259ac2a57e0ec1c4ccce79283bb50a2b6f8a9ce1acd11eb1
Install with Composer: $ composer require 'drupal/views:^3.10'
Using Composer to manage Drupal site dependencies

Release info

Created by: dawehner
Created on: 11 Feb 2015 at 09:44 UTC
Last updated: 29 Apr 2015 at 17:41 UTC
Core compatibility: 7.x
Release type: Security update, Bug fixes

Release notes

See SA-CONTRIB-2015-039 - Views - Multiple vulnerabilities

Changes since 7.x-3.8:

  • Strengthen the redirect of views locking
  • Strengthen the default configuration
  • #2007474 by dawehner: Add documentation for refreshing of a view
  • #2308885 by pfrenssen: Wrong example in documentation for hook_views_pre_view()
  • #2361507 by Pol: Added Global: View result reverse counter .
  • #2200141 by JvE: Fixed Notice: Undefined index: summary in options_validate().
  • #1995892 by hswong3i, jlyon: Fixed JS error: Cannot set property 'events' of undefined jquery.ui.dialog.patch.js:24.
  • #2305807 Follow up by olli: Fixed Undefined property: view::$changed
  • #1493210 by hass, darrenmothersele, agalitsyn: Fixed Contextual links added to page element if 'page' view is displayed.
  • #2305807 by amitgoyal, damiankloip, olli | jhodgdon: Fixed Clicking "Add" filter and then canceling dialog results in "You have unsaved changes.".
  • #1924892 by plach | impleri: Fixed Array to string conversion in views_arg_load.
  • #2112281 by Jax: Fixed Views pager translation not working, keys do not match.
  • #1831622 by joachim: Fixed boolean FieldAPI field with 'Use field label instead of the "On value" as label' option shows no labels Views filter options.
  • Use a safer way of finding the exposed form.
  • #102688 by tim.plunkett, dawehner: Use a proper reference for get_handlers

Dependencies

The selected release is the release that will be used for automated testing. Optional projects are only used for testing.

Required

Optional

No optional projects