This project is the combination of the Drupal 7 Display Suite Bootstrap Layouts
and Panels Bootstrap Layouts modules for Drupal 8.

Requirements

Note: see versions below which may indicate if you need to install the Layout Plugin module.

Installation

Install as you would normally install a contributed Drupal module. See:
https://drupal.org/documentation/install/modules-themes/modules-8 for further
information.

Configuration

Configuration will depend on which project is been use to display it, either
Display Suite or Panels. But all this project needs is to be installed.

Versions

Despite how the base theme keeps major version parity with the Bootstrap Framework, this module does not need to do the same. The layouts, currently, work for both Bootstrap 3 and Bootstrap 4 and are currently structured to handle version changes if doing so in the future becomes a requirement.

  • 8.x-3.x - This branch is no longer supported as there are several issues with it. It is highly recommended to use the 8.x-4.x branch (or higher) instead.
  • 8.x-4.x - (Drupal core < 8.3.0) This branch requires the contrib module Layout Plugin
  • 8.x-5.x - (Drupal core >= 8.3.0) This branch requires and utilizes the bundled core layout_discovery module (see https://www.drupal.org/node/2821240).
Supporting organizations: 

Project Information

Downloads