Overview

Views Bootstrap module enables you to create components following the theme structure of the Bootstrap framework all within the configuration settings of the powerful Views module.

Supports

Requirements

IMPORTANT:

  • All plug-ins are designed for default Bootstrap grid system, that are 12 columns.
  • For your Boostrap Carousel to work properly you must be using JQuery version 1.7, unfortunately Views does not work properly with JQuery 1.7 so make sure you revert to Jquery version 1.5 when you are editing any views and then change back to Jquery 1.7 when the View has been updated/saved. This is an issue with Views not Views Bootstrap module.

If you don't want to have to switch the version back and forth, use jQuery Update 7.x-2.x-dev as of 2013-May-01, or newer. This version allows you to use 1.5.1/1.7.1/1.8.2 with the added benefit of choosing which one you'd like to use for the backend/admin sections. This way you can use Bootstrap, and still edit Views. Hooray!

Versions

  • 7.x-2.x
    Twitter Bootstrap 2.x.
  • 7.x-3.x
    Twitter Bootstrap 3.x.

Recommended modules

#2461775: Port Views Bootstrap to Drupal 8 Roadmap

Sponsorship

...have a feature you'd like to sponsor? Get in touch

Support

If you've found the module particularly useful and want to say thank you, there's a wide range of stuff I'd welcome on my wish list (UK) (US).

Supporting organizations: 

Project Information

Downloads