Description

The eXtensible Catalog Drupal Toolkit is a set of Drupal modules to harvest records of the XC Schema format from a Metadata Services Toolkit (MST).

The XC NCIP Provider module doesn't sufficiently protect some URLs against CSRF. A malicious user can cause a user with "administer ncip providers" permission to alter NCIP providers by getting their browser to make a request to a specially-crafted URL.

This vulnerability is mitigated by the fact that only sites that have the XC NCIP Provider module enabled are affected.

CVE identifier(s) issued

  • CVE-2015-5508

Versions affected

  • All versions of The eXtensible Catalog (XC) Drupal Toolkit

Drupal core is not affected. If you do not use the contributed The eXtensible Catalog (XC) Drupal Toolkit module, there is nothing you need to do.

Solution

Install the latest version:

  • If you use the eXtensible Catalog (XC) Drupal Toolkit module for Drupal 6.x, upgrade to xc 6.x-1.4
  • If you use the eXtensible Catalog (XC) Drupal Toolkit module for Drupal 7.x, upgrade to xc 7.x-1.2

Also see the The eXtensible Catalog (XC) Drupal Toolkit project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at https://www.drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Follow the Drupal Security Team on Twitter at https://twitter.com/drupalsecurity

Edits to this advisory since publishing

Edited on November 24, 2015.