Closed (works as designed)
Project:
Drupal core
Version:
8.9.x-dev
Component:
install system
Priority:
Normal
Category:
Support request
Assigned:
Unassigned
Reporter:
Created:
30 Jun 2012 at 06:05 UTC
Updated:
10 Dec 2020 at 03:04 UTC
Jump to comment: Most recent
Comments
Comment #0.0
Jeffrey C. commentedFixed the typo.
Comment #1
Jeffrey C. commentedComment #2
aspilicious commentedIt is crashing on "use Drupal\Core\DrupalKernel;" are you sure you're on 5.3.13?
Comment #3
Jeffrey C. commentedI'm sorry, was using 5.2.17. Now that I've upgraded to 5.3.13, I got [error] [client 60.29.120.35] Premature end of script headers: index.php.
Comment #3.0
Jeffrey C. commented5.3.13 is actually greater than 5.3.3. Fixed the issue summary.
Comment #4
Jeffrey C. commentedDidn't see any header output in index.php though.
Comment #5
aspilicious commentedTry a new installation and be sure your environment is ok. Are you developing for d8? Or is there a reason why you're using D8 now?
Comment #6
Jeffrey C. commentedI'm using Bluehost and actually its environment should be BETTER than ok. Will try switching to another host. Not really a developer myself, just testing D8 out and trying to find some bug or error :)
Comment #7
droplet commented#1651010: Unification of drupal_exit() and drupal_page_footer() and performance boost for FPM enabled environments
Comment #8
mondrakeSame problem here. Beside
Premature end of script headers: index.php
I also get a
invalid CGI ref "/500.php"
PHP 5.3.16
Comment #9
mondrakeUpdate to #8
Upgrading PHP to 5.4.8, everything seems to be working fine.
Comment #10
codewatson commentedHad the same issues, started on on 5.2.17, couldn't get it to install, read the instructions (duh) and switched to 5.3.23, allowed me to install, but on first page load after install got "Premature end of script headers: index.php", switched to 5.4.13 and it would load.
Update: switched between the php versions just to see what would happen, and this time on the 5.3.23 I got the message "PHP's 'magic_quotes_gpc' and 'magic_quotes_runtime' settings are not supported and must be disabled." Never saw that message the first time, all I got was a 500 error. Maybe the install instructions need this listed somewhere?
Update2: Checked the 5.3.23 php ini file, and it shows both settings as "off", so.... huh?
Comment #10.0
codewatson commentedUpdated issue summary.
Comment #19
quietone commentedAs stated in #9 and #10 the error was caused by using an version of Php that Drupal did not support at the time. This is not a bug as the Php requirements are stated so changing to Support Request and closing this as works as designed.