• Advisory ID: DRUPAL-SA-CONTRIB-2009-106
  • Project: Agreement (third-party module)
  • Version: 6.x
  • Date: 2009-November-18
  • Security risk: Moderately Critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting


The Agreement module enables the display of a text-based agreement (think "Terms of Service") that users of a particular role must accept before they are given access to the site. The module does not sanitize some of the user-supplied fields, leading to a Cross Site Scripting (XSS) vulnerability.

Versions affected

Drupal core is not affected. If you do not use the contributed Agreement module, there is nothing you need to do.


Upgrade to the latest version:

Reported by

Fixed by


The security team for Drupal can be reached at security at drupal.org or via the form at http://drupal.org/contact.