Description

The Bootstrap theme enables you to integrate the Bootstrap framework with Drupal.

The theme does not sufficiently filter potential user-supplied data when it's passed to certain templates can which lead to a Persistent Cross Site Scripting (XSS) vulnerability.

CVE identifier(s) issued

  • A CVE identifier will be requested, and added upon issuance, in accordance with Drupal Security Team processes.

Versions affected

  • Bootstrap 7.x-3.x versions prior to 7.x-3.7

Drupal core is not affected. If you do not use the contributed Bootstrap theme, there is nothing you need to do.

Solution

Install the latest version:

  • If you use the Bootstrap theme from the 7.x-3.x branch, upgrade to Bootstrap 7.x-3.8

Also see the Bootstrap project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at https://www.drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Follow the Drupal Security Team on Twitter at https://twitter.com/drupalsecurity