I recently upgrade my sites to 7.50, Things seemed to be working OK after I did the upgrade, now I am suddenly getting a "HTTP ERROR 500" message with the sites. I did my usual backing up of the sites before upgrading, then after I was sure things were working AOK, I would delete the backups. SO now I have no backup of the previous version. After I discovered the problem, I installed 7.50 onto another site that I hadn't been using for anything outside of email. When I went to look at the site the same error was there. I tried other software on the unused site and things worked right, but not with Drupal 7.50. Is there some place around where I can find the previous version?

Comments

vm’s picture

yes. In the downloads section navigated using the links at the top of the site. Can also perform a goggle search for Drupal 7.44 drupal.org

are both sites on the same server? Seems to me before jumping through hoops you should make sure the server is still functioning properly. Especially since the claim is that the site was working fine immediately after updating.

St_Clinton’s picture

Thanks... The problem seems to be with my website host...

sam moore’s picture

You can get earlier releases of D7 here:
https://www.drupal.org/project/drupal/releases?api_version%5B%5D=103

A 500 is often from PHP - did you look in the Apache error log (or wherever your setup logs PHP errors)?

St_Clinton’s picture

I looked, and the problem seems to be with the site that host my sites... They are looking into it... I really don't want to switch back to WP or trying Joomla again (which was a royal pain when I tried it before giving Drupal a try and loving Drupal)

geek.geek’s picture

Hi,

Remove the main .htaccess file (it's in the root, where /sites is for example) see if it makes a difference, if it did upload the .htaccess from the D 7.5 package again, if the 500 error appeared, comment this line "Options +FollowSymLinks" with a # see if the 500 goes away?

St_Clinton’s picture

Thanks... I gave that a try and still the same 500 error. I even installed 8.x onto another site and the same problem. I contacted my host provider as the problem is something on their end... Oddly 6.x works, but I don't desire to take a step back with the software....

sam moore’s picture

Maybe the PHP version is old?
BTW I had an issue once where the client's hosting account was defaulting to PHP 4 - which was deprecated years ago. The hosting service said it was to ensure ongoing support for older applications, but it was a massive pain until I figured out what was going on.

St_Clinton’s picture

Thanks everyone for the help. I tried the different stuff you all suggested, then contacted the host. Turns out that the problem was a result of something that they did and have corrected after I contacted them. They had updated the PHP and a file wasn't changed that effected some of us. Thanks again for the help...

summit’s picture

Hi, May be wrong place, but I am not able to reach out to you. I saw your post about Weblinks: https://www.reddit.com/r/drupal/comments/5w10n2/web_links_module_for_dru...

Did you solve this. See my thread about this https://www.drupal.org/project/weblinks/issues/3128945
Sorry if this is the wrong place, but trying to reach out. Greetings,