Hi everyone,
I get this error message after updating Drupal 7.14 to 7.24 when I browse to the site (that means, homepage and just any other page tried).
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, support@XXXXX.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
I have seen this page: https://drupal.org/node/416906 but so far to no avail. I tried uncommenting the RewriteBase / in .htaccess, but that doesn't seem to do much.
Can someone help me? Please note that I'm but an amateur and by no means a software engineer or professional programmer. Just finding my way to Drupal and learning on the way.
EDIT: I also can't seem to access the forum (not Drupal) that is installed in a subdirectory. I guess this has something to do with some kind of access or permissions?
Comments
DITTO
I just "updated" from 7.22 to 7.24 if going from a functional site to "500 Internal Server Error" is an update. lol
TBG
I (temporarily) solved the
I (temporarily) solved the problem by replacing the .htaccess file by my old one. However, I presume there have been changes to that between 7.14 and 7.24. Where can I find these changes? Thanks in advance!
You can read the release
You can read the release notes for each release. Of course if you skip so many releases that's quite a lot of work. In this case you could do a diff between your old .htaccess and Drupal 7.24's, then add things that you customized in your old version back into the new .htaccess (things like uncommenting "RewriteBase /").
I feared for this, reading
I feared for this, reading all the release notes.
How do you "do a diff", as you say? I suppose that's compare the two for what's different?
I compared the two files and
I compared the two files and made the changes, testing each change. The problem seemed to be here:
I commented out both, because with either one uncommented, I got a 500 error. What consequences has this?
If you look at Drupal 7.14's
If you look at Drupal 7.14's .htaccess, you'll see that both these options were already there, so this must be a symptom of another problem (that you worked around previously by changing the .htaccess).
Options -Indexesis to prevent apache from showing a directory listing, e.g. when a page is not served by Drupal's index.php. This is good for security/privacy.Options +FollowSymLinksmay also be needed for some things to work properly, though I'm not sure of the top of my head what for.Can you check the permissions for your public_html folder (or whatever your document root folder is named), and see if it has overly broad permissions? I've seen some hosting companies where 775 will give a 500 error, try 755 instead in that case.
A diff shows the contents of
A diff shows the contents of two files side-by-side and highlights the differences. For Windows, I think e.g. Notepad++ has a plugin to do this; on Linux I use Meld. There are many other programs you could use.
Server memory spikes every few hours
Since updating to 7.24, I am getting memory spikes which overload the server (shared hosting at anhosting/midphase) and give "Internal Server Error 500" messages. Anyone else get this after the update? Everything worked fine before, and never got such errors. I thought it might have something to do with cron, so I set automatic cron runs to "Never" but the problem persists. Any experts here? ;-)
I have not seen other reports
I have not seen other reports of this. You might get some clues by running Devel module with the Query Log on.
Digit Professionals specialising in Drupal, WordPress & CiviCRM support for publishers in non-profit and related sectors
Checked the PHP 5 error log
I installed devel and had a look, but I'm no expert on this stuff unfortunately. I found a "php5_error_log" file though, in the root directory of all of my various add-on sites on that main hosting package I have (all very low-traffic installations, with no video, no streaming, very low image content, etc.) AND those logs make repeated references to being unable to "load dynamic libraries" which appear to be server issues and NOT my Drupal sites. Here are two such lines, from the end of a looooong list of identical declarations:
[14-Dec-2013 07:19:18 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/uploadprogress.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/uploadprogress.so: cannot open shared object file: No such file or directory in Unknown on line 0
[14-Dec-2013 07:19:18 America/Denver] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/memcache.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/memcache.so: cannot open shared object file: No such file or directory in Unknown on line 0
Any ideas? The folks at the hosting company are giving me the runaround on this, but I have a variety of slightly different Drupal 7 sites on other hosts (including some here in Switzerland) without a single message like this, although all the core and module versions are the same. It seems very odd that ALL of the installations (six separate add-on sites and the main host installation) only show this problem at that one single hosting company, and nowhere else... Thanks for any advice on this.
You have to sort them out one
You have to sort them out one by one. Drupal likes to have upload progress, you can ask your host to install it. The reference to memcache suggests one of the sites has memcache module installed (which it should not if it is not on the server).
The admittedly higher cost of a real Drupal specialist host is excellent value in the time and effort it saves, as well as for providing better speed. I suggest moving hosting.
If there is really a connection between the update and the memory spikes (which I take it is suspected but by no means certain) I doubt these error messages point you to it, but they should be fixed.
Digit Professionals specialising in Drupal, WordPress & CiviCRM support for publishers in non-profit and related sectors
PHP 5.4.22
Thanks for the suggestion. None of the sites involved are using the memcache module, but the hosting company responded last night, with a useful detail, finally. As a quick aside, I had specifically chosen them because they were listed on drupal.org as a "Drupal-friendly" host... Apparently, the server hosting my Drupal sites was just-recently upgraded to PHP ver. 5.4.22. They said the error messages indicate that my "software" (Drupal 7, fully updated) was trying to access files no longer used in 5.4.22 and that was the problem. I guess they are no longer "Drupal-friendly" then...
The slightly more expensive
The slightly more expensive Drupal only hosts as Drupion.com, hotdrupal.com, Civihosting.com shoulf be ok. The impression created by this site that listed hosting companies are checked and suitable is misleading.
Digit Professionals specialising in Drupal, WordPress & CiviCRM support for publishers in non-profit and related sectors
PHP 5.4 should work fine
I'm using it for various D7 sites. I even tested D6 sites on it without major issues. Maybe some contrib modules are less compatible, but all issues I've seen are about notices, not things actually breaking completely.
7.24 core only site breaks with .htaccess file accessible
Though I've off and on "played" with Drupal, I am only a newbie fascinated with Drupal and trying to get it to work. I've been successful at putting up various sites over the years through much trial and error and help from the community. I'm now coming back to Drupal...
I've had difficulty getting the core 7.24 Drupal download to work. I'm not sure I followed the directions accurately in terms of manually editing the .htaccess file (see below). I've searched quite a bit to identify possible solutions and now I'm at a dead end, and am having similar issues as other posters on this thread.
I'm on a shared hosting environment with the following details (and I will be shifting to a Drupal friendly ISP in the New Year):
PHP 5.3
MySQL 5.5.32
mod_rewrite loaded on server
i do have access to my tmp folder
I've already asked and I'm told the memory limit has been upped to 256MB (I just asked for it to be increased, and that's what they told me).
I ran into the "500 Internal Server Error" when getting to the last step of the installation. After much searching, I contacted my ISP and tried to get help there. The technician upped the memory, and nothing immediately changed. When I went back to refresh after a few minutes, my site suddenly appeared and I was able to access the admin functions. I wasn't sure what changed.
When I went to configure the site and enable clean urls, I discovered that I could not enable them, and that one possible solution was to edit the .htaccess file. When I opened my public_html file, I found that the .htaccess file had been renamed to .htaccess_old and that it was basically removed from serving its purpose. At the same time, the site was functional. In the moment I put the .htaccess file back into commission, the site broke. I am unable to figure out what portion of the .htaccess file contributed to the break. However, after searching the Drupal site, I thought it might be that mod_rewrite was not loaded on the server. ISP staff confirmed that it is loaded.
Any thoughts about what might be breaking the site (and how to get the core modules up and running?
Thanks in advance,
Eva
I'm not sure I followed the directions correctly for editing the .htaccess file with the snippets that needed to be manually added to public .htaccess, the tmp, and file .htaccess (the following is public .htaccess):
This should probably be a
This should probably be a separate thread. Anyway I would compare the two .htaccess files and list the differences. Hopefully the one you have is broadly similar.
This bit
is not part of the .htaccess which comes with Drupal core (I just downloaded a fresh copy before writing this answer to double-check). I would use that default file which comes form the version of Drupal available on this site as a starting point.
For development work best not waste time battling with an unsuitable server. Just download Drupal onto a laptop (if it is not linux you can use a VM or download Acquia Dev Desktop) and work there.
Digit Professionals specialising in Drupal, WordPress & CiviCRM support for publishers in non-profit and related sectors
Thank you...that did it.
John_B,
I had put in a help request with my ISP. Ironically, just as I read your post, the email came up saying the exact same thing. Trying to figure out what to add manually into the .htaccess file in order to get things working was a little confusing. Thank you for quick reply and your help.
Much appreciated,
Eva
Permissions 755
Setting permissions to 755 worked for me, but I'm not sure if this was a particular host issue or not.
Sustain open source projects on Gratipay
I had an issue where the
I had an issue where the server had been compromised. After updating (to 7.34) the server was giving a 500 error that none of the .htaccess solutions would work for.
I had a look at the error log (in cPanel as this is a shared host and the actual error logs are hidden away) and it showed an error with group write permissions on the index.php file.
Looking into it further I noticed that many files had chmod permissions of 664 and directories of 775 (Group write permissions turned on). I recursively changed the permissions to 644 for files and 755 for directories and that solved the 500 error.
You've been hacked: https:/
You've been hacked: https://www.drupal.org/drupalsa05FAQ
Contact me to contract me for D7 -> D10/11 migrations.
Or anything really. I'm friendly, and open to work or conversation.
500 Internal Server Error, Drupal 7.34
There is some conflict created with Apache when using the distributed .htaccess file. I worked around this problem temporarily by removing the .htaccess file from the root directory (ie. Drupal.7.3.4) structure created when unzipping the compressed download.
Although the 500 error requires further investigation, it appears there is a conflict between installation root directory .htaccess and the apache http.conf file.
I have two installations where one generates the 500 error, while a second installation with the distribution .htaccess file present does not.
My environment is a Mac OS X 10.10 with Apache/2.4.9 (Unix) PHP/5.5.14
Normally the causes of these
Normally the causes of these things are flagged up in the Apache error log.
Digit Professionals specialising in Drupal, WordPress & CiviCRM support for publishers in non-profit and related sectors
500 Internal Server Error for images in files, Drupal 7.34
The following .htaccess settings worked for me. The following part in public .htaccess should match the files directory .htaccess.
public htaccess:
# Follow symbolic links in this directory.
Options +SymLinksIfOwnerMatch
files directory htaccess:
old settings:
Options +FollowSymLinks
replaced with:
Options +SymLinksIfOwnerMatch
After updating to the new drupal version 7.34 images won't appear, because new drupal update had a little different from the old one.
After updating to the above settings my images are shown now. Hope this help.
I spent half a day to find a
I spent half a day to find a solution. I tried quite a few workarounds and tests.
Only your suggestion worked.
Thank you very much.
Having Similiar Issue
(deleted)
Similiar Issue as Well
*Resolved my own Internal 500 error finally, skip to bottom of post*
Found this thread looking up 500 internal error which I am getting with installing Drupal 7.39. Had the same with new Drupal 8. Followed several sites and suggestions for changing permissions, etc. Running a windows IIS setup. Added the app pool user, gave rights, etc. Still had that issue.
After reading this blog, I tried the older version of Drupal of 6.37 offered on the download page. it worked flawlessly.
https://www.drupal.org/project/drupal
Version Date
8.0.0-rc1 2015-Oct-07
7.39 2015-Aug-19
6.37 2015-Aug-19
Looking at those differences seems to be the key here for us at least. Just wanted to add in what we have found and seen so far. Will try to figure out those differences and what's missing so we can run the latest version of 7.
Our Resolution: (hope it helps)
Installed drupal 6 on the server instead of 7 first. Followed along and resolved many of the errors that came up in the process. One of which was to add a web.config file under windows32 directory where IIS is installed and where the mod rewrite program gets installed. This is similar to a .htaccess file but on the windows system for iis instead. After finding that text we needed, created the file, added it there, it resolved some issues for 6. I then realized that was the main error that it kept talking about for the Internal 500 error, the web.config file issue. So I went back and tried the install again, and it was there appearing and resolved.