• Advisory ID: DRUPAL-SA-CONTRIB-2013-082
  • Project: Bean (third-party module)
  • Version: 7.x
  • Date: 2013-10-23
  • Security risk: Highly critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting

Description

This module enables you to create block entities a.k.a. beans.

The module did not sufficiently filter bean titles for dangerous html.

This vulnerability is mitigated by the fact that an attacker must have permission to create or edit beans.

CVE identifier(s) issued

  • CVE-2013-4499

Versions affected

  • Bean 7.x-1.x versions prior to 7.x-1.5

Drupal core is not affected. If you do not use the contributed Bean module, there is nothing you need to do.

Solution

Install the latest version:

  • If you use the Bean module for Drupal 7.x, upgrade to Bean 7.x-1.5

Also see the Bean project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.