• Advisory ID: DRUPAL-SA-CONTRIB-2013-077
  • Project: Google Site Search (third-party module)
  • Version: 6.x, 7.x
  • Date: 2013-September-18
  • Security risk: Less critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting


This module enables you to use the Google API to search one or more sites and show the result in your Drupal site, with your custom styling.

The module doesn't sufficiently sanitize the data retrieved from the Google API.

This vulnerability is mitigated by the fact that an attack must come from the API which requires either compromising Google or spoofing DNS.

CVE identifier(s) issued

  • CVE-2013-4384

Versions affected

  • Google Site Search 6.x-1.x versions before 6.x-1.4.
  • Google Site Search 7.x-1.x versions before 7.x-1.10.

Drupal core is not affected. If you do not use the contributed Google Site Search module, there is nothing you need to do.


Install the latest version:

  • If you use the Google Site Search module for Drupal 6.x, upgrade to 6.x-1.4
  • If you use the Google Site Search module for Drupal 7.x, upgrade to 7.x-1.10

Also see the Google Site Search project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.