• Advisory ID: DRUPAL-SA-CONTRIB-2013-061
  • Project: Flippy (third-party module)
  • Version: 7.x
  • Date: 2013-July-31
  • Security risk: Less critical
  • Exploitable from: Remote
  • Vulnerability: Access bypass


This module enables you to generate previous/next links for content types.

The module doesn't sufficiently enforce node access when generating previous/next links. A user may be presented with a link (including alias if one is set) but will not be able to view the node content.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission to access content.

CVE identifier(s) issued

  • CVE-2013-4187

Versions affected

  • Flippy 7.x-1.x versions prior to 7.x-1.1

Drupal core is not affected. If you do not use the contributed Flippy module, there is nothing you need to do.


Install the latest version:

  • If you use the Flippy module for Drupal 7.x, upgrade to Flippy 7.x-1.2

Also see the Flippy project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.