• Advisory ID: DRUPAL-SA-CONTRIB-2013-037
  • Project: Rules (third-party module)
  • Version: 7.x
  • Date: 2013-March-27
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting


The Rules module allows site administrators to define conditionally executed actions based on occurring events (known as reactive or ECA rules). It's a replacement with more features for the trigger module in core.

The module contains a persistent cross site scripting (XSS) vulnerability due to the fact that it fails to sanitize rule tags before display.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission "administer rules".

CVE identifier(s) issued

  • CVE-2013-1906

Versions affected

  • Rules 7.x-2.x versions prior to 7.x-2.3.

Drupal core is not affected. If you do not use the contributed Rules module, there is nothing you need to do.


Install the latest version:

  • If you use the Rules module for Drupal 7.x, upgrade to Rules 7.x-2.3

Also see the Rules project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.