• Advisory ID: DRUPAL-SA-CONTRIB-2013-035
  • Project: Views (third-party module)
  • Version: 7.x
  • Date: 2013-March-20
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting


The Views module provides a flexible method for Drupal site designers to control how lists and tables of content, users, taxonomy terms and other data are presented.

The module incorrectly prints some view configuration fields without proper sanitization opening a Cross-Site Scripting vulnerability.

The vulnerability is mitigated by the fact that an attacker must have a role with the permission "Administer vocabularies and terms" or other administer-related permissions from contributed modules that integrate with Views.

CVE identifier(s) issued

  • CVE-2013-1887

Versions affected

  • Views 7.x-3.x versions prior to 7.x-3.6.

Drupal core is not affected. If you do not use the contributed Views module, there is nothing you need to do.


Install the latest version:

  • If you use the Views module for Drupal 7.x, upgrade to Views 7.x-3.6

Also see the Views project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.