• Advisory ID: DRUPAL-SA-CONTRIB-2012-020
  • Project: Faster Permissions (third-party module)
  • Version: 7.x
  • Date: 2012-February-15
  • Security risk: Highly critical
  • Exploitable from: Remote
  • Vulnerability: Access bypass


CVE: CVE-2012-1643

This module enables you to configure the permissions of a specific module on a separate page. This is especially handy for sites with a large list of permissions.

The module doesn't sufficiently check for the required permissions when the provided permission administration is displayed and therefore allows users without the required permissions to configure module permissions.

Versions affected

  • Faster Permissions 7.x-2.x versions prior to 7.x-1.2.

Drupal core is not affected. If you do not use the contributed Faster Permissions module, there is nothing you need to do.


Install the latest version:

See also the Faster Permissions project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Edited to link to the 7.x-1.2 release instead of the mistaken 7.x-7.2 release. Both contain the same code, but 7.x-1.2 is more appropriate for Drupal's update mechanism.