Closed (fixed)
Project:
ImageCache
Version:
6.x-2.0-beta10
Component:
Miscellaneous
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
3 Aug 2009 at 20:32 UTC
Updated:
3 Jun 2012 at 00:56 UTC
Suddenly I started getting these error messages, but not exactly sure why. Any ideas are appreciated.
warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'theme_imagecache_formatter' was given in /mysite.com/html/includes/theme.inc on line 617.
Comments
Comment #1
Branndon commentedI just upgraded to the newest version and I'm having the same issues.
Comment #2
VinceW commentedI encountered the same notices after an upgrade from 6.x-2.0-beta8 to 6.x-2.0-beta10.
The notices kept appearing on all the pages (admin and public visitors) of my testsite... however after a few (about 10 or so) page views the notices disappeared.
I noticed several other topics (other modules), like #246247: warning: call_user_func_array() after upgrade... so I assume it's not an Imagecache related issue only.
I didn't changed the version number of this queue, because it first seemed to appear in beta9, but it applies for beta10 also.
Best,
VinceW
Comment #3
jamesialford commentedhi all, I know this will sound petty, I had this issue when I upgraded the Imagecache module. I ran update.php and it solved it.
I hope this will help
Comment #4
alberto56 commented#3 is correct, but if your site cache is enabled, you also have to clear it.
This error seems to have appeared after upgrading to 6.x-2.0-beta10, so I changed the version for this issue as well.
Thanks again for the great module.
Comment #5
alberto56 commentedSorry, I somehow missed VinceW's comment about it appearing in beta9 as well, so I'm changing the version back. Cheers.
Comment #6
soupp commented#3 + #4 worked fine for me. So probably this is not a bug really but a matter of proper update handling by site admin.
Comment #7
wuh commentedThis definitely appears to be a bug. Problem is intermittent but causes images to disappear from the site. Also seems to affect the loading of other modules and / or page scripts / css files - I'm basing this on the fact that several CSS rules seem to be ignored (unloaded) when the error occurs. Clearing the cache or running update.php fixes the issue temporarily. I haven't been able to figure out what triggers this error, but all of a sudden I start seeing reams of errors in my log looking like this:
call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'theme_imagecache_formatter' was given in /home/wuh/public_html/serein.co.uk/includes/theme.inc on line 617.
Comment #8
wuh commentedThis happened again on my site last night and I was able to perform a little more debugging. I have narrowed down the cause to a record in the cache table. The record looks like this:
cid: theme_registry:mytheme
data: [BLOB - 141.5 KiB]
expire: 0
created: 1254434395
serialized: 1
If I delete it, my images return and the theme_imagecache_formatter errors stop appearing. If I re-insert the exact same record, the problems reappear.
Could this bug / issue be related to this? - http://drupal.org/node/496198
In dire need of help
Comment #9
chrisjlee commented+1
Seems like clearing the cache sometimes helps this problem go away.
I also suspect it maybe a permissions issue relating to imagecache.
Comment #10
sergivives commentedNo images where shown for me either, but I just cleared the cache as #4 said and worked like a charm!
Thanks for the help!!!
Comment #11
fizk commentedPlease reopen if this is still an issue with ImageCache 6.x-2.0-rc1.