• Advisory ID: DRUPAL-SA-CONTRIB-2009-113
  • Project: FAQ (third-party module)
  • Version: 5.x, 6.x
  • Date: 2009-December-23
  • Security risk: Moderately Critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting


The Frequently Asked Questions (faq) module allows users, with the appropriate permissions, to create question and answer pairs which are displayed on the 'faq' page, and in the random and recent FAQ blocks. The module does not sanitize some of the user-supplied data before displaying it, leading to a Cross Site Scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that the attacker must have a role with the 'administer faq', 'create faq' or 'edit faq' permissions. If using the FAQ module with the FAQ Ask module, the attacker may also exploit the vulnerability if they have the 'ask question' permission.

Versions affected

  • FAQ module 5.x-2.13 and prior versions
  • FAQ module 6.x-1.10 and prior versions

Drupal core is not affected. If you do not use the contributed FAQ module, there is nothing you need to do.


Install the latest version:

  • If you use the FAQ module for Drupal 5.x upgrade to FAQ 5.x-2.14
  • If you use the FAQ module for Drupal 6.x upgrade to FAQ 6.x-1.11

See also the FAQ module project page.

Reported by

  • stella (the module maintainer)

Fixed by

  • stella (the module maintainer)


The security team for Drupal can be reached at security at drupal.org or via the form at http://drupal.org/contact.