I have a Drupal 6 site that I want to migrate to Drupal 8. Both D6 and D8, and the additional D8 contrib modules for migrate are at the latest versions. I can import / migrate all the nodes but: the body field for every node is empty.

I have followed the instructions here: https://www.drupal.org/upgrade/migrate which involves using this module. I'm running the migrations using drush.

I've set up the reference to the drupal 6 database to be migrated as discussed here: https://www.drupal.org/node/2551147

drush migrate-upgrade --configure-only runs fine.

I run drush migrate-import --all and successfully import a lot of content (including 800+ users), and as said, the titles for all the nodes are there but the body field for every node is empty.

How do I fix this? Not sure which module I should raise an issue against? Is there a way of editing / inspecting the migrations that migrate-upgrade creates?

Output from drush migrate-import --all

Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'block_content_type'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'contact_category'
Processed 3 items (3 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_date_formats'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_dblog_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_file_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_search_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_statistics_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_cron'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_date'
Processed 1 item (0 created, 0 updated, 0 failed, 1 ignored) - done     [status]
with 'd6_system_file'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_image'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_image_gd'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_logging'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_maintenance'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_performance'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_rss'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_system_site'
Processed 2982 items (2982 created, 0 updated, 0 failed, 0 ignored) -   [status]
done with 'd6_url_alias'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_user_mail'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_user_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'menu_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'search_page'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'taxonomy_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'text_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'update_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'block_content_body_field'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_contact_settings'
Processed 7 items (7 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'menu'
Missing filter plugin: filter_null.                                      [error]
Missing filter plugin: filter_null.                                      [error]
Missing filter plugin: filter_null.                                      [error]
Processed 3 items (3 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_filter_format'
Processed 3 items (3 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_custom_block'
Processed 7 items (7 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_user_role'
Processed 60 items (18 created, 0 updated, 0 failed, 42 ignored) -      [status]
done with 'd6_block'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_comment_type'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_comment_field'
Processed 6 items (6 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node_type'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_comment_field_instance'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_comment_entity_display'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_comment_entity_form_display'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_comment_entity_form_display_subject'
Processed 11 items (6 created, 0 updated, 0 failed, 5 ignored) - done   [status]
with 'd6_field'
Processed 13 items (8 created, 0 updated, 0 failed, 5 ignored) - done   [status]
with 'd6_field_instance'
Processed 7 items (7 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_view_modes'
Processed 64 items (40 created, 0 updated, 24 failed, 0 ignored) -      [status]
done with 'd6_field_formatter_settings'
Processed 13 items (8 created, 0 updated, 0 failed, 5 ignored) - done   [status]
with 'd6_field_instance_widget_settings'
Processed 479 items (0 created, 0 updated, 479 failed, 0 ignored) -     [status]
done with 'd6_file'
Processed 32 items (32 created, 0 updated, 0 failed, 0 ignored) -       [status]
done with 'd6_menu_links'
Processed 0 items (0 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_user_picture_file'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'user_picture_field'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'user_picture_field_instance'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'user_picture_entity_display'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'user_picture_entity_form_display'
Processed 830 items (830 created, 0 updated, 0 failed, 0 ignored) -     [status]
done with 'd6_user'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_node_settings'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_upload_field'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_upload_field_instance'
Processed 1819 items (1819 created, 0 updated, 0 failed, 0 ignored) -   [status]
done with 'd6_node__article'
Processed 45 items (45 created, 0 updated, 0 failed, 0 ignored) -       [status]
done with 'd6_node__event'
Processed 21 items (21 created, 0 updated, 0 failed, 0 ignored) -       [status]
done with 'd6_node__page'
Processed 2951 items (2951 created, 0 updated, 0 failed, 0 ignored) -   [status]
done with 'd6_node__recording_data'
Migration failed with source plugin exception: SQLSTATE[42S22]:          [error]
Column not found: 1054 Unknown column
'field_recordingdata_' in 'where clause': SELECT
0 AS delta
FROM 
{content_type_recording_file} t
WHERE  (field_recordingdata_ IS NOT NULL ) AND (nid =
:db_condition_placeholder_0) AND (vid = :db_condition_placeholder_1);
Array
(
    [:db_condition_placeholder_0] => 977
    [:db_condition_placeholder_1] => 7915
)

Processed 2 items (2 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node__recording_file'
Processed 2 items (2 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node__webform'
Processed 4 items (4 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node_revision__article'
Processed 2 items (2 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node_revision__event'
Processed 7 items (7 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node_revision__page'
Processed 148 items (148 created, 0 updated, 0 failed, 0 ignored) -     [status]
done with 'd6_node_revision__recording_data'
Migration d6_node_revision__recording_file did not meet the              [error]
requirements. Missing migrations d6_node__recording_file.
requirements: d6_node__recording_file.
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_node_revision__recording_file'
Processed 1 item (1 created, 0 updated, 0 failed, 0 ignored) - done     [status]
with 'd6_node_revision__webform'
Processed 6 items (6 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node_setting_promote'
Processed 6 items (6 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node_setting_status'
Processed 6 items (6 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_node_setting_sticky'
Processed 7 items (7 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'user_profile_field'
Processed 7 items (7 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'user_profile_field_instance'
Processed 7 items (7 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'user_profile_entity_display'
Processed 7 items (7 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'user_profile_entity_form_display'
Processed 830 items (830 created, 0 updated, 0 failed, 0 ignored) -     [status]
done with 'd6_profile_values'
Processed 3 items (3 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_taxonomy_vocabulary'
Processed 28 items (28 created, 0 updated, 0 failed, 0 ignored) -       [status]
done with 'd6_taxonomy_term'
Processed 3 items (3 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_vocabulary_field'
Processed 4 items (4 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_vocabulary_field_instance'
Processed 4 items (4 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_vocabulary_entity_display'
Processed 4 items (4 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_vocabulary_entity_form_display'
Migration d6_term_node__1 did not meet the requirements. Missing         [error]
migrations d6_node__recording_file. requirements:
d6_node__recording_file.
Migration d6_term_node__2 did not meet the requirements. Missing         [error]
migrations d6_node__recording_file. requirements:
d6_node__recording_file.
Migration d6_term_node__3 did not meet the requirements. Missing         [error]
migrations d6_node__recording_file. requirements:
d6_node__recording_file.
Migration d6_term_node_revision__1 did not meet the requirements.        [error]
Missing migrations d6_node__recording_file, d6_term_node__1,
d6_term_node__2, d6_term_node__3, d6_node_revision__recording_file.
requirements: d6_node__recording_file. requirements: d6_term_node__1.
requirements: d6_term_node__2. requirements: d6_term_node__3.
requirements: d6_node_revision__recording_file.
Migration d6_term_node_revision__2 did not meet the requirements.        [error]
Missing migrations d6_node__recording_file, d6_term_node__1,
d6_term_node__2, d6_term_node__3, d6_node_revision__recording_file.
requirements: d6_node__recording_file. requirements: d6_term_node__1.
requirements: d6_term_node__2. requirements: d6_term_node__3.
requirements: d6_node_revision__recording_file.
Migration d6_term_node_revision__3 did not meet the requirements.        [error]
Missing migrations d6_node__recording_file, d6_term_node__1,
d6_term_node__2, d6_term_node__3, d6_node_revision__recording_file.
requirements: d6_node__recording_file. requirements: d6_term_node__1.
requirements: d6_term_node__2. requirements: d6_term_node__3.
requirements: d6_node_revision__recording_file.
Migration d6_upload did not meet the requirements. Missing migrations    [error]
d6_node__recording_file. requirements: d6_node__recording_file.
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_term_node__1'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_term_node__2'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_term_node__3'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_term_node_revision__1'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_term_node_revision__2'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_term_node_revision__3'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_upload'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_upload_entity_display'
Processed 5 items (5 created, 0 updated, 0 failed, 0 ignored) - done    [status]
with 'd6_upload_entity_form_display'
Processed 830 items (830 created, 0 updated, 0 failed, 0 ignored) -     [status]
done with 'd6_user_contact_settings'

I was expecting errors on the recordings_data and recordings_file nodes as there is a lot of custom code and configuration in D6 on that, but for standard pages and stories, I'm puzzled why the body content is missing?

Comments

Matt B created an issue. See original summary.

mikeryan’s picture

Status: Active » Closed (duplicate)

It's not really missing - you were using the PHP filter in your site, no? That filter is no longer part of core, so migration converts it to filter_null (see the messages in your output: Missing filter plugin: filter_null). So, the text doesn't display, but you can set your filters in affected nodes to filtered_html or somesuch and assuming the content isn't entirely PHP the content should display.

See also #2618332: Better handle replacement of missing filters with filter_null.

matt b’s picture

Status: Closed (duplicate) » Active

Mikeryan, thanks for your reply. I do use the php filter but only on a handfull of nodes. There is no body text either displayed or on the edit form for every single node imported. The field is empty. Most nodes used full html which did not have the php filter enabled.

Anonymous’s picture

StatusFileSize
new25.74 KB

I believe I am having a similar issue.

My D7 site did not have the PHP filter enabled. All of the nodes used the "Filtered HTML" format.

Upon migration, the data does get migrated, but the format for the body field is not set.

Anonymous’s picture

Checked the D8 DB...

body_format was "filtered_html_wysiwyg_", so obviously not the stock "filtered_html".

I fixed it for my case by running an SQL UPDATE query to change the body_format for all nodes to "basic_html".

matt b’s picture

Hi Brian

I need to scrutinize the database itself (my next step) but in my scenario I can not see data for the body field for all nodes imported (titles, etc are there). I have just removed the PHP filter module from the source site, rolled back and re-imported and still no data.

matt b’s picture

StatusFileSize
new149.92 KB

Screenshot of empty body field.

matt b’s picture

StatusFileSize
new364.9 KB

So I'm looking at the database. I can see that the nody_body table contains the imported data, but the body_format field is set to 'full_html1'. I change this to 'full_html' (same as when I create a node normally via the website) and can still not see the boy field contents on the website. How do I stop 'full_html1' being created and ensure that migrated nodes use 'full_html'? Why is the data not showing up in the node edit form or when viewing a node?

matt b’s picture

I can see migrate.migration.d6_filter_format and migrate.migration.d6_node_revision__article in the config tables, should I manually edit these?

mikeryan’s picture

Title: the body field for every node is empty. » Filters not properly migrated in D6 upgrade
Project: Migrate Upgrade » Drupal core
Version: 8.x-1.x-dev » 9.x-dev
Component: Code » migration system
Category: Support request » Bug report

The issue is in the results of migration, not in the migrate_upgrade UI, so moving to the core issue queue.

I don't see this problem myself when testing, but on the D8 side I'm starting from the minimal profile which doesn't create default filters as the standard profile does - it seems like it may be creating a new filter rather than overwrite the existing one. As for why text with the given filter doesn't display, I would review the roles assigned to the filters at /admin/config/content/formats.

omlx’s picture

I have this problem also. Till it gets fixed, is there any workaround ?

joel_guesclin’s picture

I have this same problem, and I think it comes from having alternative filters enabled in D6. I have a D6 site which has a number of modules set up that affect the Input Formats configuration, as follows:

  • Better Formats
  • WYSIWYG Filter
  • CKEditor Link
  • Insert Views
  • and maybe others I've forgotten about

On top of this, I'm already in D6 using the CKEditor module which has its own profile configurations.
When I look at the migrated Input Formats, I notice:

  1. There are two "Full HTML" formats, one of which is shown as having CKEditor as text editor, the other not (the machine name of the one without CKEditor as text editor is full_html1 which rather suggests that this one got copied across without replacing the existing format (maybe the thing to do is to delete the D8 default formats before beginning the migration).
  2. When I edit any of my original Text Formats, I get a warning message: "The filter_null filter is missing, and will be removed once this format is saved." I save the Text Format and lo and behold! My content magically appears!

So it looks like one workaround would be to start by disabling any extra filters in your D6 Text Formats, and deleting the default Text Formats in the D8 target.

matt b’s picture

Thanks for the responses - this has given me something to look into! Curious as to why this is now a 9.x issue and not a Drupal 8 issue?

mikeryan’s picture

Version: 9.x-dev » 8.0.x-dev

Because I fumble-fingered it?

matt b’s picture

;-)

omlx’s picture

Ok, here is my workaround.

Using Phpmyadmin navigate to node__body table (or just search it) then in SQL tab, write this:

UPDATE `node__body` SET `body_format`='full_html' WHERE `body_format`='full_html1';

Please notice the following:

in my case, I use different body format in my website so it is not good to change all body_format to full_html.
after the migration I got full_html1, but you may get different body_format.

After execution the SQL command, Clear Drupal cache

jonhattan’s picture

I confirm #12.2 is in the track.

Any missing filter (php_filter or any provided by contrib modules) is migrated as filter_null.

filter_null returns an empty string - http://cgit.drupalcode.org/drupal/tree/core/modules/filter/src/Plugin/Fi...

When viewing the format page at admin/config/content/formats/manage/% the message "The filter_null filter is missing, and will be removed once this format is saved." is shown.

Editing and saving all affected filters fixes the issue.

@mikeryan which direction you think we should follow to fix the issue?

jonhattan’s picture

Status: Active » Needs review
StatusFileSize
new1.15 KB

Here's a proposal: return an informative message for admins, instead of the empty string.

We don't have access to the format neither the entity from within the filter class, so the message can't be more friendly --although probably can have a better wording.

matt b’s picture

Taking onboard mikeryan's comment in #10 about doing a minimal install, I started with a fresh 8.0.3 install - using the minimal profile. Re-ran the migrations. Still got the failures, still no content in the body field.

I now only have the filters imported from d6. I updated these as per #12.2. Cleared the cache. Still no content. Tried to roll back the node imports and re-import. Still no content.

Looks like I'm stuck on D6 a little longer!

matt b’s picture

I did some more investigation. Older nodes are now importing fine once I had updated the filters. Newer ones weren't. Turns out some time back I'd implemented the locale module to customise some of the strings on the interface. I disabled this on source site, set the language field on the node table to empty, re-imported and now I'm seeing data in the body field!

So
- make sure locale is disabled on your source drupal 6 system.
- use the minimal profile so that you don't end up with lots of text formats.
- edit the text formats to remove any missing filters.

I'd say this is now really a documentation issue (and more informative messages as suggested by jonhatton in #18 would help).

However perhaps there is a need for better handling of text filter imports?

quietone’s picture

Issue tags: +migrate-d6-d8
boran’s picture

Is the a way to programmatically or via SQL "edit the text formats to remove any missing filters", i.e. so that one can automate D6 migrations without having to visit the UI?

catch’s picture

Priority: Normal » Major
Issue tags: +Migrate critical

Version: 8.0.x-dev » 8.1.x-dev

Drupal 8.0.6 was released on April 6 and is the final bugfix release for the Drupal 8.0.x series. Drupal 8.0.x will not receive any further development aside from security fixes. Drupal 8.1.0-rc1 is now available and sites should prepare to update to 8.1.0.

Bug reports should be targeted against the 8.1.x-dev branch from now on, and new development or disruptive changes should be targeted against the 8.2.x-dev branch. For more information see the Drupal 8 minor version schedule and the Allowed changes during the Drupal 8 release cycle.

heddn’s picture

Status: Needs review » Needs work

I can confirm this is an issue. It is because of the process plugin config for the format. This really should check if a format already exists and overwrite it, rather than de-duplicating. This is particularly troublesome if you subscribe to approach in #2711099: Categorize migrations according to their type. As your filter formats will start to proliferate like rabbits.

The patch in #18 doesn't seem to solve the root issue, so I'm marking as needs work.

process:
  format:
    -
      plugin: machine_name
      source: name
    -
      plugin: dedupe_entity
      entity_type: filter_format
      field: format
      length: 32
rivimey’s picture

I too saw this problem when porting my d6 site to d8.1.0; I solved it in a similar way to #16, which worked, though I also had to remove additional filter definitions afterwards. My old d6 site did nothing at all fancy with filters.

Contrary to the suggestion this is a docs issue, from my experience so far I think #25 is the right direction.

alvinalexander’s picture

I'm trying to port a Drupal 6.38 site to 8.1.0, and running the query in comment #16 after the initial migration process also works for me.

leandro713’s picture

i've got success in this case checking both filter formats in the origin Drupal and in the D8 one.
having identical filter formats in both before the migration everything worked fine ;)

Crell’s picture

The workaround in #16 only half-worked. Because the format can't be deleted, only disabled, if you disable it before renaming then you still can't save the "real" Full HTML format. Fun times.

Updating the existing format in-place in case of a name collision seems the better approach.

mikeryan’s picture

Issue tags: +Needs tests

Maybe a first step towards this patch would be a fail test - validate that "dupe" filters aren't created and assigned to content.

mikeryan’s picture

Status: Needs work » Needs review
StatusFileSize
new625 bytes

Actually, could it really be this simple? The only case where I think the dedupe_entity would be useful is if you had two filters (on the source side) whose names differed only in non-machine-name characters...

edit: added parenthetical statement

heddn’s picture

Status: Needs review » Needs work

We need to do (or should at least consider doing) some static mapping of 'basic_html' => 'filtered_html'

catch’s picture

Sounds like there might be two separate bugs here:

1. Formats in 6.x with missing filter plugins display blank in 8.x (but without a warning).

2. Duplicate formats

Should we split the issue?

The last submitted patch, 31: filters_not_properly-2630578-31.patch, failed testing.

mikeryan’s picture

Status: Needs work » Needs review
StatusFileSize
new604 bytes
new604 bytes

I think we found our fail test... The upgrade test uses the D8 standard profile, which creates 4 formats including Full HTML. The D6 database fixture has 4 formats, including Full HTML. Right now the upgrade test is looking to end up with 8 total formats - i.e., it's assuming the deduping process, which we've determined is undesirable. So, correcting that to 7 should fail with the existing code and succeed with this patch.

In #32, @heddn suggested that the D6 Filtered HTML format be mapped to the D8 Basic HTML format rather than creating a Filtered HTML format on the D8 side, since that is meant to be the modern equivalent (or is Restricted HTML meant for that?). I (mildly) disagree, and also am not sure adding that mapping is in the scope of this patch (fixing the dupe format issue). What do others think?

@catch: Right, I focused on the dupe format issue, the missing filter problem is a different issue which will have a different solution, so I'll open a separate issue.

mikeryan’s picture

Title: Filters not properly migrated in D6 upgrade » Filters duplicated in D6 upgrade
mikeryan’s picture

Title: Filters duplicated in D6 upgrade » Formats duplicated in D6 upgrade

So hard to keep filters and formats straight...

mikeryan’s picture

OK, opened up the separate issue #2720263: Migration of missing filters prevents content display. @jonhattan, can you resubmit your proposed patch over there?

(edit: fixed issue link)

mikeryan’s picture

StatusFileSize
new1.2 KB

Oops, didn't upload the actual fix last time...

heddn’s picture

heddn’s picture

Status: Needs review » Reviewed & tested by the community

If #39 comes back green, this is good to go.

The last submitted patch, 35: filters_not_properly-2630578-35-FAIL.patch, failed testing.

The last submitted patch, 35: filters_not_properly-2630578-35.patch, failed testing.

alvinalexander’s picture

I’m not sure I fully understand #35, but if the D6 Full HTML mapped to the D8 Full HTML, I’d have no complaints. That’s what I might have expected or hoped for.

By that logic, I wouldn’t have a problem with the D6 Filtered HTML mapping to the D8 Basic HTML format, especially if there was a comment somewhere that said “The Drupal 8 ‘Basic HTML’ format is a replacement for the Drupal 6 ‘Filtered HTML’ format.”

alexpott’s picture

Status: Reviewed & tested by the community » Fixed

Committed d564d84 and pushed to 8.1.x and 8.2.x. Thanks!

  • alexpott committed 56ebb39 on 8.2.x
    Issue #2630578 by mikeryan, jonhattan, Matt B: Formats duplicated in D6...

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.

matt b’s picture

Thanks everyone - I've finally got back to looking at my D6 migration again. Fresh D8 install and the migration with regards to body fields and text filters now works fine (once you edit and save each filter).

Rodeo.be’s picture

still issues here when upgrading D6 to D8!

cilefen’s picture

@Rodeo.be Please open a new issue and reference this one. Provide details.