• Advisory ID: DRUPAL-SA-CONTRIB-2013-085
  • Project: Feed Element Mapper (third-party module)
  • Version: 6.x
  • Date: 2013-October-30
  • Security risk: Less critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting


Feed Element Mapper is an add-on module for FeedAPI that maps elements on a feed item such as tags or the author name to taxonomy or CCK fields.
The module doesn't sufficiently filter text when displaying options to users.
This vulnerability is mitigated by the fact that an attacker must have a role with the permission "administer taxonomy".

CVE identifier(s) issued

  • CVE-2013-4503

Versions affected

All versions of the module.

Drupal core is not affected. If you do not use the contributed Feed Element Mapper module, there is nothing you need to do.


Users of the module are encouraged to evaluate the risks and mitigating factors and remove the module. There is no release with a fix available. The module is generally unsupported and users are encouraged to switch to FeedAPI suite of modules.

Also see the Feed Element Mapper project page.

Reported by

Fixed by

Not applicable.

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.