• Advisory ID: DRUPAL-SA-CONTRIB-2013-055
  • Project: Hatch (third-party theme)
  • Version: 7.x
  • Date: 2013-July-10
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting


Hatch theme is a simple and minimal portfolio theme for photographers, illustrators, designers, or photobloggers.
The theme didn't sufficiently escape user supplied text prior to printing them.
This vulnerability is mitigated by the fact that an attacker must have a role with the permission "Administer content", "Create new article", or "Edit any article type content" .

CVE identifier(s) issued

  • CVE-2013-4138

Versions affected

  • Hatch theme 7.x-1.x versions prior to 7.x-1.4.

Drupal core is not affected. If you do not use the contributed Hatch module, there is nothing you need to do.


Install the latest version:

  • If you use the Hatch theme for Drupal 7.x, upgrade to Hatch 7.x-1.4

Also see the Hatch project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.