After upgrade from 7.3.3 to 7.3.4 (also on 7.3.5) i faced following error on some pages:
Fatal error: Unsupported operand types in [path to drupal]/sites/all/modules/views/includes/handlers.inc on line 1032
File 'handlers.inc' on line 1032 contents 'add_condition' function, string:
) + $this->placeholders;
System log contains:
Notice: Undefined property: views_many_to_one_helper::$placeholders в функции views_many_to_one_helper->add_filter() (строка 1032 в файле [path to drupal]/sites/all/modules/views/includes/handlers.inc).
Following investigation shows that error exists only if contextual filter appling to taxonomy term.
Example is: http://doc20vek.ru/persons/%D0%97
Exported view in attachment.
Please help!
| Comment | File | Size | Author |
|---|---|---|---|
| #18 | views-1752062-18.patch | 544 bytes | fastangel |
| #16 | many_to_one_fix.patch | 511 bytes | aspilicious |
| #11 | views-1752062-11.patch | 479 bytes | dawehner |
| #6 | includes_handlers.inc_.git_.patch | 785 bytes | NewSky |
| #4 | includes_handlers.inc_.patch | 786 bytes | NewSky |
Comments
Comment #1
Anonymous (not verified) commentedsame Problem here
Comment #2
NSp commentedSame problem, and problem exists only with taxonomy in glossary mode
Comment #3
Anonymous (not verified) commentedYepp, right: Problem existis only in glossary mode.
Once I switch on the glossary mode, the error log says:
The durpal protocol:
Comment #4
NewSky commentedHi,
I solved the problem by replacing the code
by
in includes/handlers.inc file, in add_filter() function.
However, I don't know for the time if it causes collateral damage.
Everything seems to work for me for now ...
Comment #6
NewSky commentedComment #7
Robin Millette commentedComment #8
Raptor commentedHi, I was having an issue with contextual filters causing a HTTP 500 error and the PHP error which is listed in the bug report. After applying this patch the HTTP 500 and PHP errors / warnings stopped occuring.
http://redev.synapse.net.au/organisations/a-z/a
Comment #9
XerraX commentedconfirming that #6 works
Comment #10
Aurochs commentedConfirm patch from #6 helped me to solve the problem with latest Drupal 7.x-dev and latest views 3.5
Comment #11
dawehnerI believe this patch will fix the issue in a more easy way.
Comment #12
Countzero commentedGot 500 errors on an Ajax enabled views with taxonomy stuff, and this patch made it disappear.
Thanks.
Comment #13
jodym commentedPatch #11 worked for me, thanks.
Comment #14
slayne40 commentedSame problem ( taxonomy in glossary mode )
Patch #11 worked for me.
Thanks.
Comment #15
dawehnerThanks for testing! Committed this patch to d7.
Comment #16
aspilicious commentedThis stuff is way to complicated...
Comment #17
xjmComment #18
fastangel commentedRerolled.
Comment #19
fonant commentedPatch in #11 fixes the problem for me, Drupal 7.
Comment #20
xjmThanks @fastangel!
NW now for some tests.
Comment #21
stevenmhouse commentedD7, Views 3.5 - view using attachments - patch in #11 worked for me
Thanks
Comment #22
damiankloip commented@fastangel, tests? :)
Comment #23
fastangel commentedI am trying reproduce this error on my local but I can't attach one display. I get a list empty in 'attach to'. I was seeing the code and in the options displays the list is always empty. Is other bug?
Comment #24
jfew commentedD7.15, Views 3.5 - using a clone of the default glossary view - patch in #11 worked for me. This problem appeared only after I updated Views from v3.3 to v3.5.
Comment #25
somatics commentedI get an error which I believe is the same issue. However, I am using the latest dev version of Views (2012-Nov-11), which is significantly newer than Views version 3.5 (2012-Aug-24) and newer than when these posts say the patch was rolled into Views.
When I put any incorrect path, e.g. "cats" or "dogs", after the View's url, I get a WSOD.
It appears the Contextual Filter for <(term) Taxonomy term: Name> that I have configured for this View seems to kick in and get stuck on not being able to find the specified filter criteria. Here's the PHP error I get (I also get server error logs, which I include in the post I link to below):
Notice: Undefined property: views_many_to_one_helper::$placeholders in views_many_to_one_helper->add_filter() (line 1032 of /path-to-drupal/sites/all/modules/views/includes/handlers.inc).I had not found this issue last week, and so I posted my own issue for my situation at http://drupal.org/node/1836184
The effect of this problem is so bad, it often locks up my website!
Comment #26
bonobo commentedSetting the version back to 8.x-dev - it looks like this was unset in comment 24.
Comment #27
dawehnerSet to needs review. Not sure whether we want to have tests for that, though writing tests for many to one handler is less easy then you would expect it to be.
Comment #28
arne@dbyte.nl commentedPatch in #11 fixes the problem for me to
Comment #29
sigveio commentedNote to anyone who might come across this issue, to save you looking for it; the patch from #11 has been worked into the dev version.
(It does however not exist in 3.5 - the current stable version. You'll have to either apply the path, or use -dev, in other words.)
Comment #33
jibran#18: views-1752062-18.patch queued for re-testing.
Comment #34
jibranNW as per #20.
Comment #43
lendudeCleaning up old issues.
This code changed a lot over the years, so there is a good chance that this got fixed, but since we have no steps to reproduce this on Drupal 8, that is hard to say for sure.
Please add some steps to reproduce this on D8 or move this back to the Drupal 7 queue if it is still relevant there.
Comment #44
pameeela commentedGoing to close since there hasn't been any activity after @Lendude's follow up.