• Advisory ID: DRUPAL-SA-CONTRIB-2012-052
  • Project: Node Limit Number (third-party module)
  • Version: 6.x
  • Date: 2012-March-28
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Request Forgery


CVE: CVE-2012-2080

The Node Limit Number module enables an administrator to place limits on how many nodes may be created by each user.
Node Limit Number does not protect the delete URL against Cross Site Request Forgery attacks, allowing a malicious user to trick someone with "administer node limitnumber" permissions to unknowingly remove existing limits.

Versions affected

  • Node Limit Number 6.x-1.x versions prior to 6.x-1.2.

Drupal core is not affected. If you do not use the contributed Node Limit Number module, there is nothing you need to do.


Install the latest version:

Also see the Node Limit Number project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.