• Advisory ID: DRUPAL-SA-CONTRIB-2012-038
  • Project: Views Language Switcher (third-party module)
  • Version: 7.x
  • Date: 2012-March-14
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting

Description

CVE: CVE-2012-2064

The Views Language Switcher module enables you to provide natively-formatted links that act as Views exposed filters for i18n content being displayed by Views.
The module doesn't sufficiently filter the path output when a user manually modifies the path and makes a new request.
This vulnerability can be exploited by anonymous users.

Versions affected

  • Views Language Switcher 7.x-1.x versions prior to 7.x-1.2.

Drupal core is not affected. If you do not use the contributed Views Language Switcher module, there is nothing you need to do.

Solution

Install the latest version:

See also the Views Language Switcher project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.