• Advisory ID: DRUPAL-SA-CONTRIB-2011-056
  • Project: Webform Validation (third-party module)
  • Version: 6.x, 7.x
  • Date: 2011-November-30
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting

Description

The Webform Validation module enables you to add form validation rules to Webform components through a UI.

The module contains multiple cross site scripting (XSS) vulnerabilities due to the fact that it fails to sanitize certain user entered text prior to displaying in the browser.

This vulnerability is mitigated by the fact that an attacker must have a role with permission to update Webform nodes. Various permissions provide for this ability.

Versions affected

  • Webform Validation 6.x-1.x versions prior to 6.x-1.4.
  • Webform Validation 7.x-1.x versions prior to 7.x-1.0.

Drupal core is not affected. If you do not use the contributed Webform Validation module, there is nothing you need to do.

Solution

Install the latest version:

See also the Webform Validation project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.