I'm having this problem here: http://drupal.org/node/294538 after upgrading to Image Cache 2. I'm not sure where to paste the code from this post. I need to know where to put the code.
I received these errors when upgrading:
* user warning: Duplicate column name 'action' query: ALTER TABLE imagecache_action ADD COLUMN action varchar(255) NOT NULL DEFAULT '' in /home/pf-prod/websites/edurate.org/public_html/includes/database.mysql.inc on line 172.
* warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/pf-prod/websites/edurate.org/public_html/update.php on line 309.
* warning: Invalid argument supplied for foreach() in /home/pf-prod/websites/edurate.org/public_html/update.php on line 542.
Any help is appreciated.
Comments
Comment #1
triversedesigns commentedhaving the exact same issue....anyone?
Comment #2
triversedesigns commentedi recently seen a post that updating thickbox if your using that as well as imagefield may do the trick. Make sure imageapi is installed before upgrading imagecache aswell. WIll try further....
Comment #3
triversedesigns commentedwebster, if you install the image api, then update imagefield if needed, then upgrade thickbox, then try upgrading imagecache.
It should work, it worked for me. There seemed to be some kind of incompatibility between the modules (imagecache 2x and thickbox).
Comment #4
LarsPal commentedI'm having almost the same issue here and I'm not using the thickbox module at all: I'm getting the last two of the three warnings webster has specified.
Comment #5
triversedesigns commentedHmm that is odd, maybe try disabling imagecache, then click uninstall and uninstall imagecache, then install the new imagecache. The only issue here is that you will lose all of your imagecache presets, so maybe note them down. Make sure you do a full backup of your database before attempting any of these.
Even the demo module could be worth a look for you as well to help with this http://www.drupal.org/project/demo
Comment #6
philipnet commentedI've just upgraded from 1.6 to 2.2.
The executed queries reports shows:
imagecache module
Update #4
* ALTER TABLE {imagecache_action} ADD COLUMN action varchar(255) not null default '' after weight
* Failed: ALTER TABLE {imagecache_action} ADD COLUMN action varchar(255) NOT NULL DEFAULT ''
Did imagecache try to execute the same query twice?
I've just checked the code: it did.
There should be a "break;" at line 200 to separate the MySQL command from the PostgreSQL command.
Regards.
P.
Comment #7
spade commentedI figure from this, that I can ignore the error – do I?
Comment #8
triversedesigns commentedim fairly certain that it can be ignored, I had this on a couple of sites, they all seem to be running completely fine.
Comment #9
drewish commentedthis was resolved in #353148: imagecache update_4: "ALTER TABLE" executed twice