In Change Notice https://drupal.org/node/1800686 done by #1606794: Implement new routing system hook_menu needs a graphapi.router.yml and Controller class.

This is taken care of but

  1. the page /admin/config has no listing of link to /admin/config/system/graphapi
  2. the path /admin/config/system has no link to graphapi
  3. path /admin/config/system/graphapi/uml is not a tab on its parent page

So what menu change notice do we miss?

Comments

clemens.tolboom’s picture

I still did not manage to get the menu visible on http://drupal.d8/admin/config.

Visiting http://drupal.d8/admin/config/system/graphapi/settings is OK

clemens.tolboom’s picture

Partly fixed: 8c2b1101d135bfadab114fee15a0fe1c1e6111ed

clemens.tolboom’s picture

Title: Fix menu to router change notice » Menu to /admin/config/config no visible on /admin/config
clemens.tolboom’s picture

Title: Menu to /admin/config/config no visible on /admin/config » Menu item to /admin/config/system/graphapi has no visible entry on /admin/config
clemens.tolboom’s picture

Issue summary: View changes
clemens.tolboom’s picture

Issue summary: View changes
mgoncalves’s picture

Status: Active » Needs review
Issue tags: +ciandt-contrib
StatusFileSize
new3.56 KB

Hello @clemens.tolboom.

I tried install and work with Graph API and I could notice the issue created in this Bug.
Even knowing that this bug is assigned to you, I fixed the issues commented.

Is missing some configuration in this module and fix another ones. But now you would be able to see the configuration page and formats page.

Don't think that I tried to pass in front of you, please...I just want help.

Let me know how can we improve this module to work fine !.

Thank you so much

dhruveshdtripathi’s picture

Status: Needs review » Needs work
StatusFileSize
new12.16 KB
new16.25 KB

The page /admin/config/system/graphapi is not showing error but still no sign of visible entry on /admin/config

mgoncalves’s picture

mgoncalves’s picture

Assigned: mgoncalves » Unassigned
Status: Needs work » Needs review
StatusFileSize
new358 bytes

Hi @dhruveshdtripathi,

I added the menu links and now you can see the link configuration on "/admin/config" and "/admin/config/system".

But we need to check....
The last link (/admin/config/system/graphapi/uml) is a path to submodule (graphapi_class).
This module has a lot reference to functions of Drupal 7.
I think in this case, the best approach is make a port to D8 or create another bug to make sure that all code inside the graphapi_class is working properly.

What do you think ?

Thanks

clemens.tolboom’s picture

Status: Needs review » Needs work

It seems both #7 AND #10 are needed. So please make a unified patch.

mgoncalves’s picture

Assigned: Unassigned » mgoncalves

work on it.

mgoncalves’s picture

Assigned: mgoncalves » Unassigned
Status: Needs work » Needs review
StatusFileSize
new3.91 KB

hi @clemens.tolboom

As you asked, it's a unified patch.

Thank you

dhruveshdtripathi’s picture

Status: Needs review » Needs work

First of all, last patch throws following warning:

warning: 1 line adds whitespace errors.

And point #3 in the issue description isn't solved yet. Path /admin/config/system/graphapi/uml gives 'No page found'.

dhruveshdtripathi’s picture

Sorry, I missed comment #8. The remaining part is whitespace error.

dhruveshdtripathi’s picture

@mgoncalves has already specified about uml tab in comment #10. Are we following that approach?

mgoncalves’s picture

Status: Needs work » Needs review
StatusFileSize
new4.12 KB

Hello @dhruveshdtripathi,

I fixed errors and add some commentaries missing in the file.

About the comment #10, I think yes.
We can just check with @clemens.tolboom if he agree to make a port of this sub module.

If you (@clemens.tolboom) decided to do that, you can open this port or bug with assigned to us. :)

Thank you.

hgunicamp’s picture

Status: Needs review » Reviewed & tested by the community
StatusFileSize
new16.44 KB
new15.42 KB

I tested the 'graphapi-whitespace_error-2143593-17-8x.patch' and the links are now available as we can see below.

Only local images are allowed.

and

I'm setting this issue to "RTBC" because it seems the "/admin/config/system/graphapi/uml" issue should be a different issue.

clemens.tolboom’s picture

Status: Reviewed & tested by the community » Fixed
clemens.tolboom’s picture

Status: Fixed » Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.