Active
Project:
Field Encryption
Version:
4.x-dev
Component:
Code
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
19 Dec 2025 at 17:31 UTC
Updated:
8 Jan 2026 at 17:12 UTC
Jump to comment: Most recent, Most recent file
Comments
Comment #2
pookmish commentedLooks like it's actually coming from the StateManager service when it's loading the Kernel service in the constructor.
Comment #3
ptmkenny commentedThank you for this report.
I have never used the Default Content module; which version is causing this error?
Also, what happens if you install Drupal normally and then import from configuration? Does Field Encrypt still conflict with Default Content?
Comment #4
pookmish commentedThe version I can confirm the issue occurs is 2.0.0-alpha3 or 2.0.x-dev.
If the site is installed in any form, enabling a module with the default content or importing configuration does not encounter the error. It seems to only occur during site install.
Comment #5
ptmkenny commentedOk, thanks for the additional information. The OOP hooks implementation that this module uses is still very new (we had to rewrite the module for 11.1 and then rewrite the implementation again for additional changes in 11.3).
I'm on a break now so I'm not sure when I'll have time to look at this in detail, but for content-as-code, the Feeds module can also be used and does not have this issue.
Comment #6
pookmish commentedI know this isn't the correct solution, but it at least unblocks me with the upgrade to Drupal 11.3. Functionally, it should be the same, but it seems to prevent the error from occurring.