• Advisory ID: DRUPAL-SA-CONTRIB-2010-099
  • Project: Views Bulk Operations (third-party module)
  • Version: 6.x
  • Date: 2010-October-6
  • Security risk: Not critical
  • Exploitable from: Remote
  • Vulnerability: Access bypass


Views Bulk Operations augments Views by allowing bulk operations to be executed on the nodes and users displayed by a view. It does so by showing a checkbox in front of each item, and adding a select box containing operations that can be applied on the selected items.

In some circumstances, a malicious user could use Views Bulk Operation to cause user 0 (the anonymous user) to be deleted. The effects of deleting user 0 vary depending on the system configuration and the use of other contributed modules, ranging from trivial errors to significant loss of functionality.

The risk is mitigated by the fact that a malicious user would need permission to a view that lets him/her manage users through Views Bulk Operations in order to exploit this vulnerability.

CVE identifier(s) issued

  • CVE-2010-5277

Versions affected

  • Views Bulk Operations for Drupal 6 prior to 6.x-1.10

Drupal core is not affected. If you do not use the contributed Views Bulk Operations module, there is nothing you need to do.


Install the latest version:

See also the Views Bulk Operations project page.

Reported by

  • Joonas Kiminki (onaz)
  • Teemu Merikoski (tcmug)

Fixed by

  • Joonas Kiminki (onaz)
  • Teemu Merikoski (tcmug)


The Drupal security team can be reached at security at drupal.org or via the form at http://drupal.org/contact.