Project: 
Project machine name: 
commerce_stripe
Date: 
2026-October-28
Vulnerability: 
Cross-site request forgery
Affected versions: 
>=2.0.0 <2.2.3
CVE IDs: 
CVE-2026-118558
Description: 

This module enables you to use the Stripe Connect API to quickly configure your Drupal Commerce store to take payments via multiple Stripe APIs.

When redirecting to Stripe Connect to generate an authorization code, the module does not incorporate a CSRF token into the return URI. This could allow a an attacker to trick an administrator to click a link that bypasses Stripe payment for an order, meaning that the order would be marked as paid without any actual payment.

Solution: 

Install the latest version:

  • Upgrade to Commerce Stripe 2.2.3.
  • Commerce Stripe 2.0.x and 2.1.x are no longer supported, so sites on older versions should also update to Commerce Stripe 2.2.3.
  • Commerce Stripe 8.x-1.x is not affected.
Coordinated By: