Project: 
Project machine name: 
commerce_stripe
Date: 
2026-October-28
Vulnerability: 
Cross site scripting
Affected versions: 
>=2.0.0 <2.2.3
CVE IDs: 
CVE-2026-118560
Description: 

This module enables you to use the Stripe Connect API to quickly configure your Drupal Commerce store to take payments via multiple Stripe APIs.

Under certain rare circumstances, the module may expose a cross-site scripting vulnerability.

This vulnerability is mitigated by the fact that an attacker must have administrator permissions to configure payment gateways and use the Stripe Connect in conjunction with the compromise of an external service.

Solution: 

Install the latest version:

  • Upgrade to Commerce Stripe 2.2.3.
  • Commerce Stripe 2.0.x and 2.1.x are no longer supported, so sites on older versions should also update to Commerce Stripe 2.2.3.
  • Commerce Stripe 8.x-1.x is not affected.
Coordinated By: