Project: 
Project machine name: 
commerce_stripe
Date: 
2026-October-28
Vulnerability: 
Improper verification of cryptographic signature
Affected versions: 
<1.4 || >=2.0.0 <2.2.3
CVE IDs: 
CVE-2026-118559
Description: 

This module enables you to take payments via multiple Stripe APIs.

The module doesn't sufficiently verify the cryptographic signature of a webhook event when a signing secret has not been properly configured in the payment gateway settings.

This vulnerability is mitigated by the fact that not all payment gateway plugins in the module utilize webhooks. Furthermore, any payment gateway configuration with any value for its webhook signing secret will prevent inappropriate processing.

Solution: 

Install the latest version:

  • Upgrade to Commerce Stripe 2.2.3.
  • Commerce Stripe 2.0.x and 2.1.x are no longer supported, so sites on older versions should also update to Commerce Stripe 2.2.3.
  • If you use Commerce Stripe 8.x-1.3 or earlier, upgrade to Commerce Stripe 8.x-1.4.
Coordinated By: