Problem/Motivation

I'm trying to fix a "Composer require failure" while testing elasticsearch_helper with Drupal 9.4 and Elasticsearch library 8.0, which requires guzzlehttp/guzzle ^7.0.. When testing with D10 all is well, since it already uses guzzle 7. However, with D9 I get this error.

    - elasticsearch/elasticsearch[v8.0.0-alpha, ..., 8.6.x-dev] require guzzlehttp/guzzle ^7.0 -> found guzzlehttp/guzzle[dev-master, 7.0.0-beta.1, ..., 7.5.x-dev (alias of dev-master)] but the package is fixed to 6.5.8 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.

This because Drupal 9 can also use 6.5.8. I've added a container_command section to drupalci.yml like this:

      container_command:
        commands: "cd ${SOURCE_DIR} && sudo -u www-data composer require guzzlehttp/guzzle ^7.4.5 --with-dependencies"

But I don't see any difference in the test after pushing that: https://www.drupal.org/pift-ci-job/2551567

What am I doing wrong?

Comments

jcnventura created an issue.

jcnventura’s picture

Before that I had tried adding guzzlehttp/guzzle ^7.4.5 to the require-dev section but that didn't help also.