Hi, I have been troubles with my Drupal 8 site, it seems to work fine but after a while suddenly I get a 404 error that is fixed when clearing all cache. As a hint, I have debugged by clearing separately each type of cache: CSS and Javascript, Menus, Plugins and Static caches. But this does not fix the issue, the issue is only temporary fixed by clicking on Flush all caches options.
I have check Drupals log and it does not give me any details more than when and the url of the error 404. I have also checked php's apache's log file and nothing. Does anyone know what else the Flush all caches erases (More than the erased separately) so I can have an idea that what is happening?
Do you have an idea about how to fix it?
Thank you in advance,
Comments
Any luck with this?
Any luck with this?
I'm having similar issue with multilingual Drupal 8 site (latest stable). For some unknown reason some seemingly random subpages die to 404 error after a while and require a cache rebuild. The node address still works however, so I've been trying to narrow it down to anything that has to do with paths or URL aliases. Logs have nothing - except for the 404.
I've tried to scout around the database for any discrepancies between the stored data and cache tables, but all I've come up is that the 404 page is being cached and hit. I do not understand why all of the sudden faulty 404's end up in the cache, even if they were working fine before.
Hi
I have noticed it only happens in that specific server, I cloned the project in another server (with different software versions, apache, php, distro, etc) and the issue disappears. I think it has something to do with a buggy version of apache or something, it simply does not make sense that the same url stops working without any change.
Have you find any other clues?
I'm running nginx (and PHP 5
I'm running nginx (and PHP 5.6), but I'm starting to think it really does have something to do with the server. There is Apache on the server too, serving some legacy static content. The error seems to be impossible to reproduce on my development environment and leaves no trace besides the 404 in server logs. Might have to fire up another instance with maybe a slightly different configuration and see if the problems just disappears.
Mostly it's the one and the same page acting up too. I've tried to re-create the node several times, but this does not appear to have any effect. According to access logs, it might be that the first page load after cron ends up with 404 for some strange reason and cached version of the invalid 404 is then being served until cache is cleared once more. This does not appear to happen every time though, so for now I'm trying to still search for any sort of pattern in referrers. Couple times in the past I've also encountered an error where all the aliased paths do not work at all (ie. everything just points to node/xx), until the cache is cleared.
So all in all, no clues to share really. Seems to be a caching issue that is nigh impossible to catch and reproduce. Very, very frustrating.
I have the same problem
But didn't find any solution too.
I even don't know where to report the bug, as I don't know if this is pathauto, translate, redirect or core problem !
Yeah! I was going to
Yeah! I was going to recommend checking the server's install or, if you have a hosting provider, contacting them to ask if there's anything going on. It sounds like a server side issue.
I'm having this problem, too.
I'm having this problem, too.
I have two pages, that are almost identical in every way, other than being separate nodes with different text content on them and having unique aliases. One of them keeps disappearing, often multiple times per day, until I clear the cache. The other one has never once had that problem.
I haven't been able to figure out what's going on, but it seems like something must be invalidating that item in the alias cache or something like that.
--
Alana
I just realized that a bug
I just realized that a bug was already created for this. For anyone else running into this issue, here it is: https://www.drupal.org/node/2834638
--
Alana
Any developments?
Hi there, I was wondering if this issue had any developments? We are currently experiencing the same issue and it's really bugging us. We are now forced to completely disable the cache on one of our websites.
Could someone from the Drupal dev team comment on this? I would consider it a pretty big problem.
Are you using field_collection module?
It seemed to be something about field_collection module in multi language sites. The clean fix is to reuse the theme and custom modules in a new drupal install using Paragraphs instead, or the "dirty" one that covers the need, set a cron that runs every 3 hours that calls hook_cron() an call inside: drupal_flush_all_caches().
I have no idea of it.
I have no idea of it.
This is fixed in Drupal 8.5
https://www.drupal.org/project/drupal/issues/2802403
This happens on multilingual Drupal sites, when Drupal pages are the target values in a Link field. On a cold cache, those targeted pages can have their routing created and cached incorrectly. Updating core to 8.5.x should resolve this particular problem.
ERROR 404 after a while, clear cache fixes this. Why?
I have the same problem. Drupal 8.7.5
The problem occurs within a few days
I am also experiencing this
I am also experiencing this issue on a fairly simple/basic Drupal site with no multi-language. What's the best way to troubleshoot and track the cause of the issue?