Description

The Storage API module creates an underlying agnostic storage layer for Drupal using many different underlying storage methods. Storage API can be used to create fields for entities to hold data.

The module failed to restrict access to the Storage API fields attached to entities that are not nodes.

This is mitigated by the fact that only entities with fields using storage classes that have access restrictions are affected (they don't have by default).

CVE identifier(s) issued

  • CVE-2015-5502

Versions affected

  • Storage API 7.x-1.x versions prior to 7.x-1.8.

Drupal core is not affected. If you do not use the contributed Storage API module, there is nothing you need to do.

Solution

Install the latest version:

Also see the Storage API project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at https://www.drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.

Follow the Drupal Security Team on Twitter at https://twitter.com/drupalsecurity