• Advisory ID: DRUPAL-SA-CONTRIB-2013-075
  • Project: Click2Sell Suite (third-party module)
  • Version: 6.x
  • Date: 2013-September-11
  • Security risk: Highly critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting, Cross Site Request Forgery


Click2Sell is an Affiliate Marketing Network which lets you sell your products through their marketplace or on your website with buy it now buttons, and which also allows you to access hundreds of affiliates who want to sell your product for you and earn commission.

Reflected Cross Site Scripting (XSS)

The module doesn't sufficiently filter user supplied data when presenting a confirmation form.

Cross Site Request Forgery (CSRF)

The module doesn't properly use Drupal's Form API which allows a malicious user to trick an admin into accidentally deleting information from Click2Sell's database.

CVE identifier(s) issued

  • CVE-2013-5938 (XSS)
  • CVE-2013-5937 (CSRF)

Versions affected

  • All Click2Sell Suite 6.x-1.x versions.

Drupal core is not affected. If you do not use the contributed Click2Sell Suite module, there is nothing you need to do.


  • If you use the Click2Sell Suite module for Drupal 6.x you should disable it.

Also see the Click2Sell Suite project page.

Reported by

Fixed by

Not applicable.

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.