when adding content to panels there is an option "existing node", then new popup is displayed:

Configure new Existing node
Enter the title or NID of a node

After typing node name I could choose a node.
As have many different nodes of different content types with similar names I couldn't easily choose the right node.
It would be useful to see what is a content type of nodes displayed by autocomplete.

I hope this feature could be useful to others also.

Files: 
CommentFileSizeAuthor
#4 ctools-display-node-bundle-1844086-4.patch2.04 KBmrjmd
PASSED: [[SimpleTest]]: [MySQL] 121 pass(es).
[ View ]
#1 ctools-displaycontenttypenode-1844086-1.patch1.12 KBInternetDevels
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch ctools-displaycontenttypenode-1844086-1.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

Comments

InternetDevels’s picture

Status:Active» Needs review
StatusFileSize
new1.12 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch ctools-displaycontenttypenode-1844086-1.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

This may help.

Michelle’s picture

Project:Panels» Ctools
Version:7.x-3.x-dev»
Issue summary:View changes
Status:Needs review» Needs work

This patch is against CTools, not Panels, so I am moving the issue. I tried applying it to CTools, but it failed. Looking at the function ctools_content_autocomplete_entity(), it doesn't look anything like what's in the patch. I'm guessing that function has been rewritten in the last 1.5 years. The change is significant enough that I don't know how to fix this patch so just setting it as needs work.

Michelle’s picture

Project:Ctools» Chaos tool suite (ctools)
Version:» 7.x-1.x-dev

Fixed project.

mrjmd’s picture

Status:Needs work» Needs review
StatusFileSize
new2.04 KB
PASSED: [[SimpleTest]]: [MySQL] 121 pass(es).
[ View ]

The original patch no longer applies, and most of the relevant code has changed. Here's an attempt at reproducing the functionality.

Michelle’s picture

Status:Needs review» Reviewed & tested by the community

Patch #4 applies cleanly and does the job. Note that this also shows up when adding a node context.

The last submitted patch, 1: ctools-displaycontenttypenode-1844086-1.patch, failed testing.

mrjmd’s picture

Just adding a note, this issue is closely related to #1700544: Show vocabulary name in autocomplete results for taxonomy term contexts and they should probably be considered together.

mrjmd’s picture

  • japerry committed dbf21cc on 7.x-1.x authored by mrjmd
    Issue #1844086 by mrjmd, InternetDevels: display content type when...
japerry’s picture

Status:Reviewed & tested by the community» Fixed
Issue tags:+SprintWeekend2015

Works great. Fixed.

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.