• Advisory ID: DRUPAL-SA-CONTRIB-2012-132
  • Project: Announcements (third-party module)
  • Version: 6.x
  • Date: 2012-August-29
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Access bypass


The Announcements module creates an "announcement" content type and provides both node views and block lists.

The module doesn't sufficiently check node access under certain conditions.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission "access announcements".

CVE: Requested

Versions affected

  • Announcements 6.x-1.x versions prior to 6.x-1.5.

Drupal core is not affected. If you do not use the contributed Announcements module, there is nothing you need to do.


Install the latest version:

Also see the Announcements project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.