• Advisory ID: DRUPAL-SA-2007-001.
  • Project: Drupal Core.
  • Version: 4.6, 4.7.
  • Date: 2007-Jan-05.
  • Security risk: Less critical.
  • Exploitable from: Remote.
  • Vulnerability: Cross site scripting.


A few arguments passed via URLs are not properly sanitized before display. When an attacker is able to entice an administrator to follow a specially crafted link, arbitrary HTML and script code can be injected and executed in the victim's session. Such an attack may lead to administrator access if certain conditions are met. Learn more about XSS on Wikipedia.

Versions affected

  • Drupal 4.6.x versions before Drupal 4.6.11.
  • Drupal 4.7.x versions before Drupal 4.7.5.


Reported by

Anonymous via JPCERT.


The security contact for Drupal can be reached at security at drupal.org or via the form at http://drupal.org/contact.