This is a fresh install with drupal 4.2.0 in a postgresql setup.

There are no direct refrences to this type of error, the closest i could find was a possible createlanguage issue.

If anyone has a clue ...

Comments

emte’s picture

Well after looking for 6 hours on anything even close to that error i gaveup. i can not even figureout if it is Postgresql or PHP specific.

i guess its one of those undocumented error messages we love so much.

gaiga’s picture

I have the same with 4.2.0 and 4.1.0 on the same machine and db.
Any hint?

Anonymous’s picture

I got this error too after i first installed php, then postgresql and then drupal. The problem occurs when php have no support for your database compiled in. I am using a linux system with source code software packages and the problem was solved after recompiling php.

If you have all of the requiered files for the usage of the pear database modul in php and get this error then reinstall php or mod_php.

Anonymous’s picture

I got it too, but I'm running Windows 2000 (IIS) on a MS-SQL (2000) database, using PHP 4.3.3 and Pear....the error therefore is coming from Pear...

Cyndi’s picture

I also got this error with postgresql in debian. It went away after installing packages php4-pgsql and php4-pear.