php 4.3.3
postgresql 7.3.4
drupal 4.3.2
debian, mixed testing/unstable

I've installed drupal successfully on another debian box (running unstable) with a MySQL backend. However I'm having trouble installing on the above box using postgresql. I've searched around for the answer, but I'm stuck. Has anyone any ideas where I am going wrong?

When I try to start drupal (http://debian/drupal), I get the message "Database problem: DBError: extension not found".

I've discovered that the php.ini file has a line "extension=mysql.so". Is something similar required for postgresql?

Any help whatsoever would be appreciated.

Cheers,

Cliff

Comments

cliffp’s picture

It turns out that I was missing the php4-pgsql package. I thought I'd already got that! pgsql.so does not have to be added to php.ini, since that happens automagically. A little tweak of permissions and up popped Marvin....

Cheers,

Cliff