Composer cannot download dev version on drupal 9.1.4
composer require 'drupal/realname:1.x-dev@dev'
Your requirements could not be resolved to an installable set of packages.
Problem 1
- drupal/realname dev-1.x requires drupal/core ~8.0 -> found drupal/core[8.0.0, ..., 8.9.13] but the package is fixed to 9.1.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- Root composer.json requires drupal/realname 1.x-dev@dev -> satisfiable by drupal/realname[1.x-dev (alias of dev-1.x)].

RC2 cannot be downloaded either on drupal 9.1.4
composer require 'drupal/realname:^1.0@RC'
Your requirements could not be resolved to an installable set of packages.
Problem 1
- drupal/realname[1.0.0-rc1, ..., 1.0.0-rc2] require drupal/core ~8.0 -> found drupal/core[8.0.0, ..., 8.9.13] but the package is fixed to 9.1.4 (lock file version) by a partial update and that version does not match. Make sure you list it as an argument for the update command.
- Root composer.json requires drupal/realname ^1.0@RC -> satisfiable by drupal/realname[1.0.0-rc1, 1.0.0-rc2].

Comments

toamit created an issue. See original summary.

ikeigenwijs’s picture

same issue

toamit’s picture

Issue summary: View changes
philltran’s picture

Status: Active » Closed (duplicate)
Related issues: +#3101961: Drupal 9 Deprecated Code Report

Hi. I updated the dev branch to work with Drupal 9. I still want to do some testing. Then I will make a release for Drupal 8 /9.

For now can you try

composer require 'drupal/realname:1.x-dev@dev'

Please test and report your experience. Thanks!

toamit’s picture

@philltran thanks for fixing this. I did a functional test and it works.
Any chance this commit could go into the next release candidate?

philltran’s picture

@toamit Thanks for testing. Yes it will