The Postmark module allows the administrator to switch the standard SMTP library over to use the third party Postmark API to send out emails from their site. An account with Postmark is required to use this module.

IMPORTANT NOTICE FOR DRUPAL 7 USERS

On April 5, 2013, version 0.5 of the Postmark PHP library was released. Currently only the 7.x-1.x-dev version of Postmark supports the 0.5 library. If you download the 7.x-1.2 release of Postmark, use the 0.4.5 library available here:

https://github.com/Znarkus/postmark-php/tree/4c5b7d6487e32b76a19120bb181

The upcoming 7.x-1.3 release of Postmark will include support for the 0.5 library.

Also note that Libraries module 2.0 or higher is required for Postmark 7.x-1.2 and higher releases.

Users of the Drupal 6 version of the Postmark module can ignore this notice since the 0.4.5 release of Postmark PHP is bundled into the Drupal 6 module folder.

Sponsors

Module development is sponsored by SiteBasin (http://sitebasin.com). The Drupal 6 version of the module was sponsored by Deeson Online (http://www.deeson.co.uk/online).

If you have any requests or problems using the module, please submit an issue in the Postmark queue (http://drupal.org/project/issues/postmark).

Sender Signature Requirement

The Postmark service requires that the "from" email address be registered with them as a Sender Signature. This will normally be your Site Information email address. More information is available here.

Drupal 7

The Drupal 7 version of Postmark is dependent on the Mail System and Libraries modules. The Libraries module must be version 2.0 or higher.

Project Information

Downloads