The media module included in 2.17 seems to throw the following error:
Fatal error: Cannot redeclare media_file_default_displays_alter() (previously declared in /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/media/media.module:803) in /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/media/media.file_default_displays.inc on line 61
The media_vimeo module included in 2.17 seems to throw the following error:
Fatal error: Cannot redeclare media_vimeo_file_default_displays() (previously declared in /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/media_vimeo/includes/media_vimeo.formatters.inc:206) in /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/media_vimeo/media_vimeo.file_default_displays.inc on line 65
Updating to the latest version of the media and media_vimeo modules fixed the above errors.
Now I have to investigate several warnings listed below:
Warning: Invalid argument supplied for foreach() in _features_override_remove_ignores() (line 415 of /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/features_override/features_override.export.inc).
Warning: Invalid argument supplied for foreach() in _features_override_remove_ignores() (line 415 of /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/features_override/features_override.export.inc).
Notice: Undefined offset: 1 in conditional_fields_features_export_render() (line 49 of /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/conditional_fields/includes/conditional_fields.features.inc).
Notice: Undefined offset: 1 in conditional_fields_features_export_render() (line 49 of /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/conditional_fields/includes/conditional_fields.features.inc).
Notice: Undefined offset: 1 in conditional_fields_features_export_render() (line 49 of /home/xxxx/public_html/xxxx/profiles/openatrium/modules/contrib/conditional_fields/includes/conditional_fields.features.inc).
PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'xxxx_xxxx.cache_entity_field_collection_item' doesn't exist: TRUNCATE {cache_entity_field_collection_item} ; Array ( ) in cache_clear_all() (line 165 of /home/xxxx/public_html/xxxx/includes/cache.inc).
I have updated to the newer versions of features_override and conditionals_fields module but that does not fix these warnings.
Any advice?
Comments
Comment #1
Rockmeister commentedSorry, forgot to mention the above errors and warnings when running update.php!
Comment #2
mpotter commentedWe will be updating media in the next release after Panopoly has a chance to do more testing with it.
For now, just keep running the update.php (or "drush updb") until there are not any updates left. The updates don't run "cleanly" for many of the modules. It shouldn't affect the operation of the site.
Comment #3
jkingsnorth commentedMarking this as fixed since nothing has come back. Please reopen the issue against the latest version if this is still a problem.
Comment #5
Dalkh commentedThe problem still continues:
PHP Fatal error: Cannot redeclare media_file_default_displays_alter() (previously declared in /../profiles/openatrium/modules/contrib/media/media.module:803) in /../profiles/openatrium/modules/contrib/media/media.file_default_displays.inc on line 61
Drush command terminated abnormally due to an unrecoverable error.
Error: Cannot redeclare media_file_default_displays_alter() (previously declared in /../profiles/openatrium/modules/contrib/media/media.module:803) in
/../profiles/openatrium/modules/contrib/media/media.file_default_displays.inc, line 61
The external command could not be executed due to an application error.
These are the notifications:
Notice: Undefined index: #entity_type in manualcrop_media_element_process() (line 395 of /../profiles/openatrium/modules/contrib/manualcrop/manualcrop.module).
Notice: Undefined index: #bundle in manualcrop_media_element_process() (line 396 of /../profiles/openatrium/modules/contrib/manualcrop/manualcrop.module).
Notice: Undefined index: #field_name in manualcrop_media_element_process() (line 397 of /../profiles/openatrium/modules/contrib/manualcrop/manualcrop.module).
Notice: Undefined index: #media_options in manualcrop_media_element_process() (line 402 of /../profiles/openatrium/modules/contrib/manualcrop/manualcrop.module).
Notice: Undefined index: global in manualcrop_media_element_process() (line 402 of /../profiles/openatrium/modules/contrib/manualcrop/manualcrop.module).
Comment #6
mpotter commentedDoesn't sound like you are properly updating your OA distribution as noted here: https://www.drupal.org/node/2169701
Be sure you have reverted your features, cleared cache, etc. Not seeing these problems in v2.20 so only reopen if 2.20 still has this issue and you are following the documented update process.
Comment #7
rol commentedi got same error during fresh install.... with version 7.x-2.21
Comment #8
nikita.izotov commentedDid anyone fixed this issue?
I have this error almost on every admin page
Comment #9
mpotter commentedReopen this issue if it's still happening in v2.23 along with the exact steps to reproduce it. Be sure you have followed the update instructions and have reverted your features and cleared cache.
Comment #10
candelas commentedI was having the issue with manualcrop and updating it to the last dev https://www.drupal.org/node/2092911 it goes away. I followed all the steps in the manual to install. I reopen for you to know. Thanks for the great work in Open Atrium.
Comment #11
mpotter commentedPlease open a ticket in the Panopoly issue queue (drupal.org/project/panopoly) to have them test and update the latest version of manualcrop. They might need to wait till manualcrop makes a new release.
But Open Atrium depends upon Panopoly for the crop functionality, so it's something that needs to be updated there.
Comment #12
jkingsnorth commentedSetting this back to closed.
Comment #13
candelas commented@mpotter I made the issue https://www.drupal.org/node/2401473 Thanks for your work :)