Hi,

I'm trying out your module. I followed the documentation and believe I have things configured properly. However I get the following import error:

Import error: Could not fetch XML for i10009

Does this module only work with certain versions of the Millenium OPAC? Does the OPAC have to have a certain Innovative module in place?

Thanks. This has the makings to be an excellent tool for libraries.

Comments

mcunningham’s picture

You need to make sure you have xrecord turned on for item records. I think the wwwoption is xrectype.

janusman’s picture

Right!

If this is already in place, send me the webopac's base URL so I can have a look.

samato’s picture

I'm having the same issue. I do have the xrectype set for bib and item. Here's a sample URL from our catalog:

http://phebe.bowdoin.edu/record=b1981438~S1

Any ideas?

Also, is there any way to include more than one catalog ?

janusman’s picture

@samato: I was able to crawl some records with no problem, perhaps your settings have a problem?

Here is how I set it up:
base url: http://phebe.bowdoin.edu/
Auto-crawl: enabled
Starting ITEM record: 1000010
Restart crawl... (check the box)

Then run /cron.php ... at this point some records will be imported (the first should be i1000010, " Follies : architecture for the late-twentieth-century landscape") depending on how many you set the module to crawl with each run. I set it to "10" and got ten records =)

See an imported record in one of our Drupal sites here: http://rebiesne.mty.itesm.mx/book/1984/churchill-winston/churchill-roose...

Did this help at all?

samato’s picture

I tried this again, double checking the settings, and still have the same problem.
E.g. Import error: Could not fetch XML for i1000042

though if I go to http://phebe.bowdoin.edu/xrecord=i1000042 in a browser, I do get an xml record.

I've been playing around with this on an offsite isp, and see in their faq that allow_url_fopen is set to “Off” in php.ini. Could that be the problem (it is php 5.2) ??

(and I'm still curious if it is possible to configure import from multiple millennium sites - what fun :) )

samato’s picture

Turns out it was the allow_url_fopen, which is now enabled and I no longer get this error. I have a zillion other questions now that I have real data (yippee!) but will play around with it for a while to see if the answer become obvious ;^)

janusman’s picture

Status: Active » Closed (fixed)

Closing, not a module problem per se (although I guess I should put it in the README somewhere)