This project is not covered by Drupal’s security advisory policy.

Hack core without incurring divine retribution on pre-adolescent feline kind.

This module is not for the faint of heart. You will need to use Runkit, and chances are good that this will involve checking out code from the PHP CVS and building it with PECL. And once you've got all of that running, this module gives you the tools to let you shoot yourself in the foot.

Developers: To use this module (assuming you have runkit and the module is installed), you will need to implement hook_kitten_bling() in your module. Currently, hook_kitten_bling is fired in hook_boot, which means that you cannot use this module to override early bootstrapping in Drupal.

For maximum irresponsibility with minimal effort, you can get Runkit precomiled for MAMP here: http://technosophos.com/content/php-5-runkit-mamp-172

Requirements

To use kitten, you must have Bad Judgement already.

Project information

  • caution Minimally maintained
    Maintainers monitor issues, but fast responses are not guaranteed.
  • caution Maintenance fixes only
    Considered feature-complete by its maintainers.
  • chart icon811 downloads
  • shield alertThis project is not covered by the security advisory policy.
    Use at your own risk! It may have publicly disclosed vulnerabilities.

Downloads