This notice is being issued - line 86 of imageapi/imageapi_imagemagick.module on the image toolkit admin page - /#overlay=admin/config/media/image-toolkit

Blank d7-x install with just imageapi as extra module - only imageapi imagemagick enabled.


chrissearle’s picture

Could be me - I only had the imageapi imagemagick module - not the imageapi module. This error disappeared when the imageapi module was also enabled. Should there be some dependency setting there?

eosrei’s picture

I receive the same error with both ImageAPI and ImageAPI ImageMagick installed when I save the configuration.

pyrollo’s picture

I've got the same problem and it seems ImageMagick is not usable.

Step to reproduce :

  • Perform a new installation of Drupal 7.0 beta 3, 2010-11-13
  • Copy imageapi module (version 7.x-1.x-dev timestamp 1287360749) into sites/mysite/modules
  • Enable both ImageAPI and ImageAPI UmageMagick modules
  • Go to Administration/Configuration/Media/Image Toolkit
  • Choose "ImageMagick toolkit" and validate
  • Validate second page (on wich you choose ImageMagick path)

Message displayed is :

Notice: Undefined index: #post in imageapi_imagemagick_validate_path() (line 86 of /srv/principal/www/d7/sites/mysite/modules/imageapi/imageapi_imagemagick.module).

If I go further, trying to use ImageMagick, here is what happens :

Steps :

  • Enable Image module
  • Go to Administration/Configuration/Media/Image styles
  • Click on any style

Message displayed is :

Warning: Division by zero in theme_image_style_preview() (line 772 of /srv/principal/www/d7/modules/image/
Warning: array_intersect_key(): Argument #1 is not an array in theme_image_style_preview() (line 774 of /srv/principal/www/d7/modules/image/
Warning: Division by zero in theme_image_style_preview() (line 789 of /srv/principal/www/d7/modules/image/
Warning: array_intersect_key(): Argument #1 is not an array in theme_image_style_preview() (line 791 of /srv/principal/www/d7/modules/image/

No image is displayed. Clicking on effect result "view actual size" link, I get a "Error generating image." page.

pyrollo’s picture

imageapi_imagemagick.module, line 86 :

if ($element['#post'] == 'imageapi_imagemagick' && $errors = _imageapi_imagemagick_check_path($element['#value'])) {

According to Forms API reference, there is no "#post" property for elements. The test on $element['#post'] looks a bit strange and I don't understand its purpose. Removing it makes the configuration page working well. It may be the solution.

drewish’s picture

it's there to ensure that the error message is only being displayed once.

drewish’s picture

at least in the d6 version. it should probably be removed in favor of a d7 approach.

pyrollo’s picture

I opened another issue here about the "division by zero" problem. It includes a patch that solve the "Undefined index: #post" problem.

pyrollo’s picture

I tested this on drupal 7.0-rc2 today, and I still have the same issue.

lsolesen’s picture

Any progress?

IWasBornToWin’s picture

It's been about a year and a half since this was reported. I just installed this mod and have same issue. Any solution?

leoklein’s picture

I got the same warning. I switched back to 'GD2 image manipulation toolkit', uninstalled the imagemagick module and everything worked (including the images showing up).

Just a guess but this probably means the server I'm using isn't set up for imageMagick.