Closed (works as designed)
Project:
Forward
Version:
6.x-1.14
Component:
Code
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
17 Nov 2009 at 00:13 UTC
Updated:
25 Feb 2012 at 20:05 UTC
I'm getting the following error when trying to use the forward module:
* The submitted from address (b_wright@cais.orgb_wright@cais.org) is not valid.
* Unable to send e-mail. Please contact the site admin, if the problem persists.
The problem is maybe fairly obvious: the email address is repeated. I've tried with multiple user accounts and always get the same error. If I look at the html source of the 'forward this page' form it looks like:
<input maxlength="256" name="yemail" id="edit-yemail" size="58" value="b_wright@cais.org" disabled="disabled" class="form-text required" type="text">
So, the address is not there twice in the value argument of the input tag. Any ideas? Thanks in advance for any help.
Comments
Comment #1
ggalan1173 commentedHi, my issue is similar, but not the address repeteated twice but no address present:
"The submitted from address (gggggg <>) is not valid."
any help?
thanks
Comment #2
seanrOdd; I can't seem to reproduce this. What do you have in the forward module's settings for the default from address?
Comment #3
bwright commentedThanks for the reply. I have tried it with a couple of valid email addresses (webmaster@mydomain.com, info@mydomain.com) and also with that field left blank in the settings. However, when actually submitting the form it always fills in the address of the currently logged in user.
Comment #4
duncanc commentedggalan1173 - in case you have not solved this yet, I think that your problem is the same as the one described in these two issues http://drupal.org/node/649296 and http://drupal.org/node/624260
There are patches attached to those nodes which should solve the problem (but I have not tried either).
Comment #5
seanrShould be fixed in the next release. Thanks.
Comment #7
sja1 commentedHi,
I've upgraded to 6.x-1.14 (was on 1.10) and am still getting this error. On 6.x-1.10 I was getting the same version of the error as in comment #1. After updgrading the module I get a message like "The submitted from address (name
<email@address.com>) is not valid."I also see the following message appear in my watchdog:
Type php
Date Viernes, 19 de marzo, 2010 - 23:02
User bubba
Location http://www.yaq.es/forward?path=node%2F11419
Referrer http://www.yaq.es/forward?path=node%2F11419
Message Missing argument 2 for theme_forward_page() en la línea 17 del archivo path_to_forward_module_directory/forward/forward.theme.
Severity error
I performed a grep on the drupal directory to see which file contains this error message, and it resides in the SMTP module (I'm on the latest version of this module: 6.x 1.0-beta 4). If I turn off the SMTP module, the error messages go away.
Please let me know if I should file this bug against the SMTP module instead.
Comment #8
sja1 commentedI tracked it down to a problem with the SMTP module. There was a preg_match meant to parse emails of the format "name" " that wasn't working. The dev version of the module fixes that. (Actually, I didn't install the dev version, I just copied the new preg_match line from the dev version, and used it to modify my copy of the beta-4).
But then a new problem came up.
The emails were now getting sent, but the body of the messages was the word "Array", instead of being the proper text.
On a hunch, I went into the forward module settings and clicked the "Use forward.tpl.php template instead of old style theme functions" check box, and cleared the template cache.
This seems to clear the last hurdle, and now forward emails are getting sent properly, with proper body text.
Not sure, but it looks like the fact that the email body is corrupt if the "forward.tpl.php template" checkbox isn't checked might be a bug.
Comment #9
john.oltman commented