This project is not covered by Drupal’s security advisory policy.

This module contains deprecated validators for field validation 2.x
Following validators deprecated.

  • Numeric values (optionally specify min and / or max value)
  • Minimum length
  • Maximum length
  • Minimum number of words
  • Maximum number of words
  • Minimum number of selections required
  • Maximum number of selections allowed
  • Exact number of selections required
  • Custom PHP function
  • Match another field (or entity property)

If you want to update from field validation 1.x to 2.x, you need this module to make your update path much easier.
After you update to 2.x, you need reconfigure your validation rule, then disable this module.

Sponsors:

Field validation 2.x contains all function of these deprecated validators.

Most deprecated still work correctly, some maybe contains some bugs, such as custom PHP function when you update to 2.x.

Project information

  • caution Minimally maintained
    Maintainers monitor issues, but fast responses are not guaranteed.
  • caution Maintenance fixes only
    Considered feature-complete by its maintainers.
  • chart icon7 sites report using this module
    956 downloads
  • shield alertThis project is not covered by the security advisory policy.
    Use at your own risk! It may have publicly disclosed vulnerabilities.

Downloads