fckeditor_screenshot.jpg

CKEditor module: CKEditor is the successor to FCKeditor and has its own CKEditor module. The FCKeditor module will not receive any new features, nor will it be updated for Drupal 7. Upgrading to CKEditor is recommended for all users of FCKeditor.

WYSIWYG editor

This module allows Drupal to replace textarea fields with the FCKeditor - a visual HTML editor, sometimes called WYSIWYG editor. This HTML text editor brings many of the powerful WYSIWYG editing functions of known desktop editors like Word to the web. It's relatively lightweight and doesn't require any kind of installation on the client computer.

Note: This module is not affiliated with the WYSIWYG module. WYSIWYG offers in principle the same: an FCKeditor (or other editors) instead of normal textareas. The approach of WYSIWYG is slightly different, and users unsatisfied with the FCKeditor module are encouraged to try out the WYSIWYG module (and vice versa).

Demo site

Please visit the demo site to see a sample installation of Drupal with FCKeditor enabled.

On the same site you will also find more information about installing/configuring FCKeditor, including the video: "Install FCKeditor in Drupal in 7 minutes" and troubleshooting section.

Who's using FCKeditor?

Here is just a small list of people, projects and sites that are using FCKeditor today.

Browser compatibility

FCKeditor is compatible with most of the internet browsers, including

  • Internet Explorer 5.5+
  • Firefox 1.0+
  • Mozilla 1.3+
  • Netscape 7+
  • Opera 9.5+ (FCKeditor 2.5+)
  • Safari 3.0+ (FCKeditor 2.5+)

Drupal compatibility

There are releases for drupal 4.7, drupal 5 and drupal 6. Older releases are available from CVS.
The 6.x-1.x release of fckeditor.module is fully compatible with FCKeditor 2.6.1+.
The 5.x-2.x release of fckeditor.module is fully compatible with FCKeditor 2.6.1+.
The 5.x-1.2 release of fckeditor.module works with the 2.4.x versions of the FCKeditor component.
The 4.x release of fckeditor.module works with the 2.4.x versions of the FCKeditor component.

Required components

To use FCKeditor in Drupal, you will need to download FCKeditor

More information and licence

For further information please refer to: the FCKeditor homepage

Image/File browser

The integrated file management needs a bit of manual configuration, more information about this is in the included readme.txt file.

At the moment there are several options for using images in FCKeditor.

  1. The built in filemanager, which needs some manual configuration.
  2. The IMCE module which needs almost no configuration.
  3. The Image Browser module
  4. The Web File Manager module (available in FCKeditor dev release only at this moment)
  5. The Image Assist module
  6. The upload module - which allows file and image attachments to nodes. By copying the URL of the attachment you can use it in the FCKeditor dialog.

Please remember that enabling visitors to upload files to your site can be a serious security risk, don't give that access to users you don't trust... and exercise caution anyway.

Add to favorites!

If you like this module, help other people find it by adding FCKeditor to favorites at drupalmodules.com!

Project Information

Downloads