I am trying to add a node reference filter to a view. The node reference is pointing to a referenced type which has >50k existing nodes in the database. I am unable to get past the first step in the Add filter criteria dialog, seeing just the spinner, and after a while the operation times out (PHP Fatal error: Maximum execution time of 300 seconds exceeded). I have tried to set max_execution time to unlimited (0) in php, but then it just loads 'forever'.

It appears to me as if the code is trying to load each referenced node first, maybe to display a select option on the next page. Is this true? And could it be turned off?

Comments

LiceBaseAdmin created an issue. See original summary.

licebaseadmin’s picture

Version: 7.x-1.x-dev » 7.x-1.5
Issue summary: View changes

I confused this module version with Node reference filter
Other Node reference filter Module Enabled 7.x-2.1

So the version of this module is:
Views Views Reference Filter Module Enabled 7.x-1.5
(entityreference_filter)

But I am not quite sure if this is the right place to ask this question even, apologies in case it is not.

maximpodorov’s picture

I think it's a bad idea to add a filter pointing to a huge data set.

maximpodorov’s picture

Priority: Major » Normal
Status: Active » Closed (works as designed)

And this module doesn't load entities to show the list.